[lfs-support] can't compile gcc pass 1

Bruce Dubbs bruce.dubbs at gmail.com
Fri Jan 4 17:11:15 PST 2013


matthew gruda wrote:
> When I try to compile gcc from 5.5 I get this after running make:
>
> checking for complex.h... yes
> checking for library containing creal... -lm
> checking whether creal, cimag and I can be used... yes
> checking for an ANSI C-conforming const... yes
> checking for size_t... yes
> checking for gettimeofday... yes
> checking for localeconv... yes
> checking for setlocale... yes
> checking for dup... yes
> checking for dup2... yes
> checking for __gmpz_init in -lgmp... yes
> checking for MPFR... no
> configure: error: libmpfr not found or uses a different ABI (including
> static vs shared).
> make[1]: *** [configure-mpc] Error 1
> make[1]: Leaving directory `/mnt/lfs/src/gcc-build'
> make: *** [all] Error 2
>
> the output of the version check script is:
>
> bash, version 4.2.24(1)-release
> /bin/sh -> /bin/dash

Fix this.

> Binutils: (GNU Binutils for Ubuntu) 2.22
> bison (GNU Bison) 2.5
> /usr/bin/yacc -> /usr/bin/bison.yacc
> bzip2,  Version 1.0.6, 6-Sept-2010.
> Coreutils:  8.13
> diff (GNU diffutils) 3.2
> find (GNU findutils) 4.4.2
> GNU Awk 3.1.8
> /usr/bin/awk -> /usr/bin/gawk
> gcc (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3
> (Ubuntu EGLIBC 2.15-0ubuntu10.3) 2.15
> grep (GNU grep) 2.10
> gzip 1.4
> Linux version 3.7.0-030700-generic (root at gomeisa) (gcc version 4.6.3
> (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #201212102335 SMP Tue Dec 11 04:36:24 UTC
> 2012
> m4 (GNU M4) 1.4.16
> GNU Make 3.81
> patch 2.6.1
> Perl version='5.14.2';
> GNU sed version 4.2.1
> tar (GNU tar) 1.26
> version-check.sh: line 30: makeinfo: command not found

And fix this too.

> Texinfo:
> xz (XZ Utils) 5.1.0alpha
> gcc compilation OK
>
> im running ubuntu 12.04 and i have not deviated from the book

   -- Bruce




More information about the lfs-support mailing list