[lfs-support] booting don't work with UUIDs

Sven Bartscher svenbartscher at yahoo.de
Tue Jan 29 04:42:05 PST 2013


Am 23.01.2013 18:03, schrieb Bruce Dubbs:
> Sven Bartscher wrote:
>> hey guys!
>> I didn't installed GRUB in the chapter 8 and configured my already
>> installed GRUB
>
> That's OK.
>
> with writing the following text in the /boot/grub.cfg
>>
>> set default=0
>> set timeout=5
>>
>> insmod ext2
>> set root=(hd0,msdos4) #i tried it with set root=(hd0,4) too
>>
>> menuentry "GNU/Linux, Linux 3.5.2-lfs-7.2" {
>> linux /boot/vmlinuz-3.5.2-lfs-7.2
>> root=UUID=4f9f6834-c55b-492e-a70c-4e3bca952f5b ro
>> }
>
> The kernel doesn't understand UUIDs. You need an initrd. See BLFS
>
> http://www.linuxfromscratch.org/blfs/view/svn/postlfs/initramfs.html
>
> -- Bruce
>
>> I can't use the /dev/sdxy partition names because i have two hard drives
>> (IDE and SATA) and the names are after rebooting randomly mixed. So i
>> can't be sure which is the right /dev/sdxy file.
>>
>> I try to boot my new lfs system and it don't work instead i get this
>> message (a little bit more but i think this is the important part):
>> VFS: Cannot open root device "UUID=4f9f6834-c55b-492e-a70c-4e3bca952f5b"
>> or unknown-block(0,0): error -6
>> Please append a correct "root=" boot option; here are the available
>> partitions:
>> Kernel panic - not syncing: VFS: Unable to mount root fs on
>> unknown-block(0,0)
>>
>> I don't use an extra /boot partition so i have two /boot folders one on
>> my Ubuntu(containing GRUB and the Ubuntu kernel) partition and one on my
>> LFS (containing the LFS kernel) partition can this work?
>> Can i even use UUIDs for lfs?
>> Did i anything else wrong?
>>
>> my host system: Ubuntu 12.10
>> my lfs version 7.2
>>
>
>
>
I have created an initramfs. Here the log:

root:/# mkinitramfs
Creating initrd.img-no-kmods... cp: Aufruf von stat f�r 
�/etc/udev/udev.conf� nicht m�glich: Datei oder Verzeichnis nicht gefunden
install: Aufruf von stat f�r �/usr/share/mkinitramfs/init.in� nicht 
m�glich: Datei oder Verzeichnis nicht gefunden
done.
root:/#

and installed cpio. Here my new grub.cfg menuentry for LFS:

menuentry "GNU/Linux, Linux 3.5.2-lfs-7.2" {
insmod ext2
insmod part_msdos #Is this necessary? I have an msdos partition table
set root=(hd0,msdos4)
linux /boot/vmlinuz-3.5.2-lfs-7.2 
root=UUID=4f9f6834-c55b-492e-a70c-4e3bca952f5b ro
initrd /boot/initrd.img-no-kmods
}

I get still the same Error.



More information about the lfs-support mailing list