[lfs-support] iso8859-15 spanish accented characters in lfs-7.5

Bruce Dubbs bruce.dubbs at gmail.com
Sat May 24 06:58:58 PDT 2014


ALZ (phyglos.org) wrote:

> I can now CONFIRM this behavior after building a clean LFS SVN-20140519.
>
> Just after first boot, in console prompt, accented characters like à are
> displayed as 'a. All other characters are well placed, like Ñ, ç, €,
> etc. This happens also using a spanish AT keyboard with
> /etc/sysconfig/console set to:
>
> KEYMAP="es"
> KEYMAP_CORRECTIONS="euro2"
> FONT="lat0-16 -m 8859-15"
>
> Setting also this values in /etc/sysconfig/rc.site does not correct the
> problem.

That is just an alternative way of setting the environment variables 
above.  Any set in rc.site that are also set in /etc/sysconfig/console 
are overridden by the latter file.

> Executing "#loadkeys /usr/share/keymaps/i386/qwerty/es" seems to correct
> the problem with accents, but this is lost after reboot.
>
>> What I am trying to do is to se the encoding in console.
>> What it works for me is to use at the prompt the following;
>> loadkeys /usr/share/keymaps/i386/qerty/es.map.gz
>> but I would like it to have it loaded at boot time, if possible.
>>
>
> This is a quick workaround to temporary fix this:
>
> # mv /etc/rc.d/init.d/console /etc/rd.c/init.d/console.ORIG
>
> # cat > /etc/rc.d/init.d/console << "EOF"
>
> cd /usr/share/keymaps/i386/qwerty
>
> loadkeys es
> loadkeys euro2

If you look at /etc/init.d/console, then you will see that it should do 
exactly what you have.

> setfont lat0-16 -m 8859-15

Except this is done first.

If you can put a few echo statements in /etc/init.d/console and see 
where there is a problem, I can update the script.

   -- Bruce



More information about the lfs-support mailing list