[lfs-support] iso8859-15 spanish accented characters in lfs-7.5

Ken Moffat zarniwhoop at ntlworld.com
Sat May 24 08:17:49 PDT 2014


On Sat, May 24, 2014 at 04:18:58PM +0200, ALZ (phyglos.org) wrote:
> On 05/24/2014 03:58 PM, Bruce Dubbs wrote:
> 
> >If you can put a few echo statements in /etc/init.d/console and see
> >where there is a problem, I can update the script.
> >
> >   -- Bruce
> 
> Thanks Bruce. After some troubleshooting I've realized that in LFS this two
> commands are not equivalent:
> 
> #loadkeys es
> 
> #loadkeys /usr/share/keymaps/i386/qwerty/es
> 
> The former is what LFS bootscripts end executing from /etc/sysconfig/console
> (from KEYMAP=es) while the later is the right command to be run to solve
> this issue.
> 
> So, the way to set /etc/sysconfig/console in order to work with spanish
> accented vowels in LFS 7.5 + SVN right now is:
> 
> # Begin /etc/sysconfig/console
> 
> KEYMAP="/usr/share/keymaps/i386/qwerty/es"
> KEYMAP_CORRECTIONS="euro2"
> FONT="lat0-16 -m 8859-15"
> 
> # End /etc/sysconfig/console
> 
> I don't know the root cause of this behavior. Either Viktor and I do have a
> rare kernel option set when compiling the kernel and "#loadkeys es" invokes
> some default kernel table (just speculating here), or kbd-2.0.1 needs now
> the full path to be set in LFS rc.d scripts.
> 
> The Changelog inside kbd sources says that at kdb-1.5.3 an enviroment
> variable LOADKEYS_KEYMAP_PATH is introduced. In fact, when doing
> 
> #export LOADKEYS_KEYMAP_PATH=/usr/share/keymaps/i386/qwerty
> #loadkeys es
> 
> the expected behavior is now obtained.
> 
> If LFS scripts are to be updated after kbd-1.5.3+ is now beyond my LFS
> knowledge.
> 
> ALZ.
> 

 I find that strange, but I cannot dispute those results on your
machines.  On my own, things are different - despite the comment in
the console script "Native English speakers probably don't have
/etc/sysconfig/console at all" I do have one of these, both for my
own font and for my own keymap (uk-utf : uk with a lot of extras
added).  And my map does get loaded.

 At the moment I'm timing a xulrunner build in X on 7.5, so I went
to a tty on this machine and tried (as root) "loadkeys es" - got a
spanish keymap.  I didn't try changing the font (mine already covers
all Spanish glyphs, except a couple only used in Asturian).  I also
did not try setting the euro2 override.

 Took me a while to find where '-' had moved to, then I typed
"loadkeys uk-utf" - it failed, I got an error message (something
about hte file's content and EOL) despite loadkeys uk-utf working
during bootup.  For now, 'loadkeys uk' worked.

 I then booted another machine, with a recent copy of LFS-svn, and
confirmed that it was definitely using my uk-utf map after booting.

 My tests have all been on x86_64, with a framebuffer console.

ĸen
-- 
das eine Mal als Tragödie, dieses Mal als Farce



More information about the lfs-support mailing list