[lfs-support] LFS 7.10 systemd - boot OK on SSD thunderbolt but fail with USB3

Ken Moffat zarniwhoop at ntlworld.com
Wed Jul 4 16:50:56 PDT 2018


On Wed, Jul 04, 2018 at 07:52:48PM +0200, DOMINIQUE VAYSSAIRAT wrote:
> Hello Word,
> 
> Please, does someone have an idea for the problem below :
> 
> I built a lfs 7.10 / systemd machine on three stages :
> 	1 - on a virtual machine under virtualbox
> 	2 - many tries on a physical machine (which is a macbook pro) and using several different externals disks (SSD, SD cards) plugged on a USB ports
> 	3 - finally i get success with a SSD plugged on a thunderbolt port
> 
> First and third tries are OK/
> Second trie end with a kernel panic each time.
> I think that the problem is about USB because on the screen of the kernel panic I see that the kernel do not found the / partition.
> I tried with boot=/dev/sda4 , boot=UUID=xxx and finally boot=PARTUUID=xxx with the same result
> 
> The third trie start correctly, the external disk used has two ports : USB-3 and Thunderbolt and one can use it in others circumstances alternatively  (either USB or Thunderbolt)
> When i plug it with thunderbolt  ==> OK
> Without any change plugging it with USB ==> kernel panic
> The only-one différence is the cable and connected port.
> 
> All the kernel is compiled without module option but only with =y
>  
> Regards, Dominique 
> 
A couple of thoughts:

1. Booting from external USB drives has often been a bit iffy, in
particular kernels have needed a delay before the drive would
appear.  No idea if that applies to USB-3.

2. The USB-3 drivers are XHCI in kernel config - make sure you have
ALL the XHCI options enabled, at least until it works.

Also, of course, 7.10 is old and there have been a LOT of kernel
vulnerability fixes since then (or Meltdown on intel CPUs, gcc-8 is
required).  So once you have managed to get it booting from external
USB-3 you should probably plan on building a new system.

ĸen
-- 
              Keyboard not found, Press F1 to continue


More information about the lfs-support mailing list