[lfs-support] Booting LFS with systemd

Hazel Russman hazeldebian at googlemail.com
Tue Jul 10 00:01:13 PDT 2018


On Fri, 29 Jun 2018 01:25:29 -0400
Michael Shell <list1 at michaelshell.org> wrote:

> On Thu, 28 Jun 2018 16:06:00 +0800
> Xi Ruoyao <ryxi at stu.xidian.edu.cn> wrote:
> 
> > Now I only use "initrd" directive to update CPU microcode and fix the
> > buggy ACPI DSDT of my laptop (another sad story).  
> 
> 
>   Xi,
> 
> If you are also inclined to allow firmware to be contained within the
> kernel, the microcode part you can achieve via the 
>  
> CONFIG_FIRMWARE_IN_KERNEL=y
> CONFIG_EXTRA_FIRMWARE="amd-ucode/microcode_amd_fam15h.bin"
> CONFIG_EXTRA_FIRMWARE_DIR="/lib/firmware"
> 
> kernel config options under Device Drivers > Generic Driver Options.
> CONFIG_EXTRA_FIRMWARE points to microcode file within the given
> CONFIG_EXTRA_FIRMWARE_DIR= path. Though you'll have to rebuild the
> kernel though if the microcode file ever changes, of course.
> 
> And as there now seems to be several people who suffer with the
> ACPI DSDT driver bug, you guys should make sure upstream is aware
> of the problem, if they aren't already.
> 
> There is also a recent kernel option, acpi=copy_dsdt that attempts to
> fix bad DSDT tables. It might be worth a try if you haven't done tried
> it already.
> 
>   Cheers,
> 
>   Mike
> 
> -- 
Just to say that I've now tried the "acpi=copy_dsdt" boot option (without using my corrective initrd) and it doesn't stop the 4.15 kernel from panicking on my main machine. But thanks anyway. 

Funnily enough, my Samsung laptop (which is another old banger) boots 4.15 with full acpi and without any problems at all.

-- 
Hazel


More information about the lfs-support mailing list