[lfs-fr] r1411 - in trunk/lfs: . bootscripts/lfs/init.d chapter01 chapter05 chapter06 prologue

jmengual at linuxfromscratch.org jmengual at linuxfromscratch.org
Sam 3 Sep 11:03:36 PDT 2011


Author: jmengual
Date: 2011-09-03 20:03:36 +0200 (Sat, 03 Sep 2011)
New Revision: 1411

Modified:
   trunk/lfs/bootscripts/lfs/init.d/rc
   trunk/lfs/chapter01/changelog.xml
   trunk/lfs/chapter05/binutils-pass1.xml
   trunk/lfs/chapter05/binutils-pass2.xml
   trunk/lfs/chapter05/glibc.xml
   trunk/lfs/chapter06/binutils.xml
   trunk/lfs/chapter06/glibc.xml
   trunk/lfs/general.ent
   trunk/lfs/packages.ent
   trunk/lfs/prologue/hostreqs.xml
Log:
Mise a jour VO.


Modified: trunk/lfs/bootscripts/lfs/init.d/rc
===================================================================
--- trunk/lfs/bootscripts/lfs/init.d/rc	2011-09-03 10:43:21 UTC (rev 1410)
+++ trunk/lfs/bootscripts/lfs/init.d/rc	2011-09-03 18:03:36 UTC (rev 1411)
@@ -100,7 +100,10 @@
    done
 fi
 
-[ "${previous}" = "N" ] && IN_BOOT=1
+if [ "${previous}" = "N" ]; then
+   IN_BOOT=1
+   export IN_BOOT
+fi
 
 #Start all functions in this runlevel
 for i in $( ls -v /etc/rc.d/rc${runlevel}.d/S* 2> /dev/null)

Modified: trunk/lfs/chapter01/changelog.xml
===================================================================
--- trunk/lfs/chapter01/changelog.xml	2011-09-03 10:43:21 UTC (rev 1410)
+++ trunk/lfs/chapter01/changelog.xml	2011-09-03 18:03:36 UTC (rev 1411)
@@ -38,6 +38,23 @@
 
 -->
     <listitem>
+      <para>03-09-2011</para>
+      <itemizedlist>
+        <listitem>
+          <para>[bdubbs] - Correction de la version du répertoire extrait de 
+          binutils dans les instructions de construction de binutils. Ceci
+          sera inversé dès la prochaine version en amont, lorsque la version
+          de l'archive tar sera de nouveau synchronisée avec le nom du
+          répertoire.</para>
+        </listitem>
+        <listitem>
+          <para>[bdubbs] - Correction des scripts de démarrage pour exporter 
+          correctement la variable IN_BOOT.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
+    <listitem>
       <para>31-08-2011</para>
       <itemizedlist>
         <listitem>

Modified: trunk/lfs/chapter05/binutils-pass1.xml
===================================================================
--- trunk/lfs/chapter05/binutils-pass1.xml	2011-09-03 10:43:21 UTC (rev 1410)
+++ trunk/lfs/chapter05/binutils-pass1.xml	2011-09-03 18:03:36 UTC (rev 1411)
@@ -77,7 +77,8 @@
 
     <para>Maintenant, préparez la compilation de Binutils :</para>
 
-<screen><userinput remap="configure">../binutils-&binutils-version;/configure \
+<!-- <screen><userinput remap="configure">../binutils-&binutils-version;/configure \ -->
+<screen><userinput remap="configure">../binutils-&binutils-dir;/configure \
      --target=$LFS_TGT --prefix=/tools \
      --disable-nls --disable-werror</userinput></screen>
     <variablelist>

Modified: trunk/lfs/chapter05/binutils-pass2.xml
===================================================================
--- trunk/lfs/chapter05/binutils-pass2.xml	2011-09-03 10:43:21 UTC (rev 1410)
+++ trunk/lfs/chapter05/binutils-pass2.xml	2011-09-03 18:03:36 UTC (rev 1411)
@@ -53,7 +53,8 @@
 
 <screen><userinput remap="configure">CC="$LFS_TGT-gcc -B/tools/lib/" \
    AR=$LFS_TGT-ar RANLIB=$LFS_TGT-ranlib \
-   ../binutils-&binutils-version;/configure --prefix=/tools \
+   <!-- ../binutils-&binutils-version;/configure - -prefix=/tools \ -->
+   ../binutils-&binutils-dir;/configure --prefix=/tools \
    --disable-nls --with-lib-path=/tools/lib</userinput></screen>
 
     <variablelist>

Modified: trunk/lfs/chapter05/glibc.xml
===================================================================
--- trunk/lfs/chapter05/glibc.xml	2011-09-03 10:43:21 UTC (rev 1410)
+++ trunk/lfs/chapter05/glibc.xml	2011-09-03 18:03:36 UTC (rev 1411)
@@ -81,7 +81,7 @@
 <screen><userinput remap="configure">../glibc-&glibc-version;/configure --prefix=/tools \
     --host=$LFS_TGT --build=$(../glibc-&glibc-version;/scripts/config.guess) \
     --disable-profile --enable-add-ons \
-    --enable-kernel=2.6.22.5 --with-headers=/tools/include \
+    --enable-kernel=2.6.25 --with-headers=/tools/include \
     libc_cv_forced_unwind=yes libc_cv_c_cleanup=yes</userinput></screen>
 
     <variablelist>
@@ -114,10 +114,11 @@
       </varlistentry>
 
       <varlistentry>
-        <term><parameter>--enable-kernel=2.6.22.5</parameter></term>
+        <term><parameter>--enable-kernel=2.6.25</parameter></term>
         <listitem>
           <para>Ceci indique à Glibc de compiler la bibliothèque avec le support
-          des noyaux Linux 2.6.18 et supérieurs. Les environnements pour des noyaux plus anciens ne sont pas activés.</para>
+          des noyaux Linux 2.6.25 et supérieurs. Les contournements pour les
+          noyaux plus anciens ne sont pas activés.</para>
         </listitem>
       </varlistentry>
 

Modified: trunk/lfs/chapter06/binutils.xml
===================================================================
--- trunk/lfs/chapter06/binutils.xml	2011-09-03 10:43:21 UTC (rev 1410)
+++ trunk/lfs/chapter06/binutils.xml	2011-09-03 18:03:36 UTC (rev 1411)
@@ -79,7 +79,8 @@
 
     <para>Préparez la compilation de Binutils :</para>
 
-<screen><userinput remap="configure">../binutils-&binutils-version;/configure --prefix=/usr \
+<!-- <screen><userinput remap="configure">../binutils-&binutils-version;/configure - -prefix=/usr \ -->
+<screen><userinput remap="configure">../binutils-&binutils-dir;/configure --prefix=/usr \
     --enable-shared</userinput></screen>
 
     <para>Compilez le paquet :</para>

Modified: trunk/lfs/chapter06/glibc.xml
===================================================================
--- trunk/lfs/chapter06/glibc.xml	2011-09-03 10:43:21 UTC (rev 1410)
+++ trunk/lfs/chapter06/glibc.xml	2011-09-03 18:03:36 UTC (rev 1411)
@@ -129,7 +129,7 @@
 
 <screen><userinput remap="configure">../glibc-&glibc-version;/configure --prefix=/usr \
     --disable-profile --enable-add-ons \
-    --enable-kernel=2.6.22.5 --libexecdir=/usr/lib/glibc</userinput></screen>
+    --enable-kernel=2.6.25 --libexecdir=/usr/lib/glibc</userinput></screen>
 
     <variablelist>
       <title>Voici la signification des options de configure :</title>

Modified: trunk/lfs/general.ent
===================================================================
--- trunk/lfs/general.ent	2011-09-03 10:43:21 UTC (rev 1410)
+++ trunk/lfs/general.ent	2011-09-03 18:03:36 UTC (rev 1411)
@@ -1,7 +1,7 @@
 <?xml version="1.0" encoding="ISO-8859-1"?>
 
-<!ENTITY version "SVN-20110831">
-<!ENTITY releasedate "31 août 2011">
+<!ENTITY version "SVN-20110903">
+<!ENTITY releasedate "3 septembre 2011">
 <!ENTITY copyrightdate "1999–2011">
 <!ENTITY milestone "7.0">
 <!ENTITY generic-version "development"> <!-- Use "development", "testing", or "x.y[-pre{x}]" -->

Modified: trunk/lfs/packages.ent
===================================================================
--- trunk/lfs/packages.ent	2011-09-03 10:43:21 UTC (rev 1410)
+++ trunk/lfs/packages.ent	2011-09-03 18:03:36 UTC (rev 1411)
@@ -34,6 +34,7 @@
 <!ENTITY bash-ch6-sbu "1.4 SBU">
 
 <!ENTITY binutils-version "2.21.1a">
+<!ENTITY binutils-dir "2.21.1">
 <!ENTITY binutils-size "18,553 Kio">
 <!ENTITY binutils-url "&gnu;binutils/binutils-&binutils-version;.tar.bz2">
 <!ENTITY binutils-md5 "bde820eac53fa3a8d8696667418557ad">
@@ -296,7 +297,7 @@
 <!ENTITY less-ch6-du "3.5 Mio">
 <!ENTITY less-ch6-sbu "moins de 0.1 SBU">
 
-<!ENTITY lfs-bootscripts-version "20110830">                 <!-- Scripts depend on this format -->
+<!ENTITY lfs-bootscripts-version "20110903">                 <!-- Scripts depend on this format -->
 <!ENTITY lfs-bootscripts-size "BOOTSCRIPTS-SIZE Kio">         <!-- Updated in Makefile -->
 <!ENTITY lfs-bootscripts-url "&downloads-root;lfs-bootscripts-&lfs-bootscripts-version;.tar.bz2">
 <!ENTITY lfs-bootscripts-md5 "BOOTSCRIPTS-MD5SUM">           <!-- Updated in Makefile -->

Modified: trunk/lfs/prologue/hostreqs.xml
===================================================================
--- trunk/lfs/prologue/hostreqs.xml	2011-09-03 10:43:21 UTC (rev 1410)
+++ trunk/lfs/prologue/hostreqs.xml	2011-09-03 18:03:36 UTC (rev 1411)
@@ -82,19 +82,20 @@
     </listitem>
 
     <listitem>
-      <para><emphasis role="strong">Noyau Linux 2.6.22.5</emphasis>
+      <para><emphasis role="strong">Noyau Linux 2.6.25</emphasis>
       (compilé avec GCC-4.1.2 ou supérieur)</para>
 
-      <para>Cette version du noyau est requise car nous spécifions cette version-là lors de la construction de
-      <application>glibc</application> au chapitre 6, suivant ainsi une recommandation 
-      des développeurs.</para>
+      <para>Cette version du noyau est requise car nous spécifions cette 
+      version-là lors de la construction de
+      <application>glibc</application> au chapitre 6, suivant ainsi une 
+      recommandation  des développeurs. Elle est aussi exigée par Udev</para>
 
-      <para>Si le noyau hôte est plus ancien que le 2.6.22.5, ou s'il n'a pas
+      <para>Si le noyau hôte est plus ancien que le 2.6.25, ou s'il n'a pas
       été compilé avec le compilateur GCC-4.1.2 (ou supérieur),
       vous devrez remplacer le noyau par un nouveau qui satisfait ces
       spécifications. Vous pouvez employer deux méthodes pour cela.
       Vous pouvez d'abord voir si votre distribution Linux fournit un paquet
-      pour le noyau 2.6.22.5 ou supérieur. Si tel est le cas, vous pouvez l'installer. Si
+      pour le noyau 2.6.25 ou supérieur. Si tel est le cas, vous pouvez l'installer. Si
       votre distribution n'offre pas un paquet acceptable pour le noyau, ou si vous
       préférez l'installer, vous pouvez compiler un noyau 2.6 vous-même.
       Les instructions pour la compilation du noyau et la configuration du




More information about the lfs-traducfr mailing list