[lfs-fr] r6713 - in trunk/blfs: general/genutils general/prog introduction/welcome multimedia/videoutils networking/mailnews networking/netprogs networking/textweb traduc/commits

myou72 at orange.fr myou72 at orange.fr
Mar 30 Déc 04:13:38 PST 2014


Author: myou72
Date: 2014-12-30 04:13:38 -0800 (Tue, 30 Dec 2014)
New Revision: 6713

Removed:
   trunk/blfs/traduc/commits/r15266.txt
   trunk/blfs/traduc/commits/r15267.txt
   trunk/blfs/traduc/commits/r15268.txt
   trunk/blfs/traduc/commits/r15269.txt
   trunk/blfs/traduc/commits/r15270.txt
   trunk/blfs/traduc/commits/r15271.txt
   trunk/blfs/traduc/commits/r15272.txt
   trunk/blfs/traduc/commits/r15273.txt
   trunk/blfs/traduc/commits/r15274.txt
Modified:
   trunk/blfs/general/genutils/graphviz.xml
   trunk/blfs/general/prog/doxygen.xml
   trunk/blfs/general/prog/ruby.xml
   trunk/blfs/introduction/welcome/changelog.xml
   trunk/blfs/multimedia/videoutils/mplayer.xml
   trunk/blfs/networking/mailnews/mailx.xml
   trunk/blfs/networking/mailnews/mutt.xml
   trunk/blfs/networking/netprogs/wget.xml
   trunk/blfs/networking/textweb/links.xml
Log:
->r15274

Modified: trunk/blfs/general/genutils/graphviz.xml
===================================================================
--- trunk/blfs/general/genutils/graphviz.xml	2014-12-29 12:36:07 UTC (rev 6712)
+++ trunk/blfs/general/genutils/graphviz.xml	2014-12-30 12:13:38 UTC (rev 6713)
@@ -121,6 +121,17 @@
          /usr/share/doc/graphviz-&graphviz-version;</userinput>
 </screen>
   </sect2>
+  <sect2 role="commands">
+    <title>Command Explanations</title>
+    <para>
+      <command>sed "s:ruby-1.9:ruby-2.2:g" -i configure</command>: Utilisez cette commande si 
+      ruby-2.2.0 est installé et que vous souhaitez construire
+      <application>Graphviz</application> avec le support pour lui.
+    </para>
+  </sect2>
+
+
+
     <sect2 role="configuration">
     <title>Configuration de Graphviz</title>
     <sect3 id="graphviz-config">

Modified: trunk/blfs/general/prog/doxygen.xml
===================================================================
--- trunk/blfs/general/prog/doxygen.xml	2014-12-29 12:36:07 UTC (rev 6712)
+++ trunk/blfs/general/prog/doxygen.xml	2014-12-30 12:13:38 UTC (rev 6713)
@@ -66,9 +66,11 @@
     <para role="optional">
       <xref linkend="graphviz"/>,
       <xref linkend="gs"/>,
-      <xref linkend="python2"/>,
-      <xref linkend="qt4"/> (pour doxywizard) et
-      <xref linkend="texlive"/>
+      <xref linkend="llvm"/> (avec clang),
+      <xref linkend="python2"/> ou <xref linkend="python3"/>,
+      <xref linkend="qt4"/> (pour doxywizard),
+      <xref linkend="texlive"/>, et
+      <xref linkend="xapian"/> (pour doxyindexer)
     </para>
     <para condition="html" role="usernotes">Notes utilisateur :
     <ulink url="&blfs-wiki;/doxygen"/></para>
@@ -100,12 +102,23 @@
   <sect2 role="commands">
     <title>Explication des commandes</title>
     <para><option>--with-doxywizard</option> : Utilisez ce paramètre
-    si <application>Qt</application> est installé et si vous souhaitez construire
+    si <application>Qt4</application> est installé et si vous souhaitez construire
     l'interface graphique. Si <application>Qt4</application> et
       <application>Qt5</application> sont installés, utilisez
       <command>source setqt4</command>. Si <application>Qt4</application> est
       installés dans <filename class="directory">/opt</filename>, tapez
       <command>export QTDIR=$QT4DIR</command>.</para>
+
+    <para>
+      <option>--with-doxysearch</option>: Utilisez ce paramètre si 
+      <application>xapian</application> est installé et que vous souhaitiez construire
+      les outils de recherche externes (doxysearch et doxyindexer).
+    </para>
+    <para>
+      <option>--with-libclang</option>: tilisez ce paramètre si
+      <application>llvm</application> avec <application>clang</application> sont isntallé, pour
+      ajouter le support pour l'analyse de libclang.</para>
+
   </sect2>
   <sect2 role="configuration">
     <title>Configuration de Doxygen</title>
@@ -165,6 +178,32 @@
           </indexterm>
         </listitem>
       </varlistentry>
+      <varlistentry id="doxyindexer">
+        <term><command>doxyindexer</command></term>
+        <listitem>
+          <para>
+            génère un index de recherche appelé <filename>doxysearch.db</filename>
+            depuis un ou plusieurs fichiers de données produits par
+            <command>doxygen</command>. voir <ulink
+            url="http://www.stack.nl/~dimitri/doxygen/manual/extsearch.html"/>.
+          </para>
+          <indexterm zone="doxygen doxyindexer">
+            <primary sortas="b-doxyindexer">doxyindexer</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+      <varlistentry id="doxysearch.cgi">
+        <term><command>doxysearch.cgi</command></term>
+        <listitem>
+          <para>
+            est un programme CGI pour chercher des données indéxées par
+            <command>doxyindexer</command>.
+          </para>
+          <indexterm zone="doxygen doxysearch.cgi">
+            <primary sortas="b-doxysearch.cgi">doxysearch.cgi</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
     </variablelist>
   </sect2>
 </sect1>

Modified: trunk/blfs/general/prog/ruby.xml
===================================================================
--- trunk/blfs/general/prog/ruby.xml	2014-12-29 12:36:07 UTC (rev 6712)
+++ trunk/blfs/general/prog/ruby.xml	2014-12-30 12:13:38 UTC (rev 6713)
@@ -72,6 +72,18 @@
 <userinput>./configure --prefix=/usr               --enable-shared             --docdir=/usr/share/doc/ruby-&ruby-version; &&
 make</userinput>
 </screen>
+
+     <para>
+      Facultativement, construisez les documents CAPI en lançant les commandes suivantes :
+    </para>
+<screen><userinput>cp -v template/Doxyfile.tmpl Doxyfile &&
+doxygen</userinput></screen>
+    <para>
+      Compilez et liez <application>Ruby</application> en lançant la commande suivante:
+    </para>
+<screen><userinput>make</userinput></screen>
+
+
     <para>Pour tester les résultats, lancez : <command>make test</command>.</para>
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 <screen role="root">
@@ -103,14 +115,13 @@
       <segtitle>Répertoires installés</segtitle>
       <seglistitem>
         <seg>
-          erb, gem, irb, rake, rdoc, ri, ruby et testrb
+          erb, gem, irb, rake, rdoc, ri et ruby 
         </seg>
         <seg>
-          libruby.so, libruby-static.a et de nombreux modules situés dans la hiérarchie
-         <filename class="directory">/usr/lib/ruby</filename>.
+          libruby.so et libruby-static.a </filename>.
         </seg>
         <seg>
-           /usr/include/ruby-2.1.0,
+           /usr/include/ruby-&ruby-version;
           /usr/lib/ruby,
           /usr/share/doc/ruby-&ruby-version; et
 		  /usr/share/ri

Modified: trunk/blfs/introduction/welcome/changelog.xml
===================================================================
--- trunk/blfs/introduction/welcome/changelog.xml	2014-12-29 12:36:07 UTC (rev 6712)
+++ trunk/blfs/introduction/welcome/changelog.xml	2014-12-30 12:13:38 UTC (rev 6713)
@@ -16,10 +16,191 @@
   <para>Version actuelle : &version; – &releasedate;</para>
   <itemizedlist>
     <title>Entrées dans l'historique des changements :</title>
+
+    <listitem>
+      <para>28 Décembre 2014</para>
+      <itemizedlist>
+        <listitem>
+          <para>[fernando] - ruby-2.2.0: correction de la construction des docs capi et des statistiques
+         pour rendre plus explicite la partie documentation.</para>
+        </listitem>
+        <listitem>
+          <para>[fernando] - graphviz-2.38.0: correction de la construction avec ruby-2.2.0.</para>
+        </listitem>
+        <listitem>
+          <para>[fernando] - Passage à doxygen-1.8.9. Corrige
+          <ulink url="&blfs-ticket-root;5983">#5983</ulink>.</para>
+        </listitem>
+        <listitem>
+          <para>[igor] - Passage à links-2.9. Corrige
+          <ulink url="&blfs-ticket-root;5980">#5980</ulink>.</para>
+        </listitem>
+        <listitem>
+          <para>[fernando] - exim-4.84: change URL.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
+    <listitem>
+      <para>27 Décembre 2014</para>
+      <itemizedlist>
+        <listitem>
+          <para>[ken] - Security fix for mutt-1.5.23.</para>
+        </listitem>
+        <listitem>
+          <para>[ken] - Passage à heirloom-mailx-12.5 incluand des correction de sécurité.</para>
+        </listitem>
+        <listitem>
+          <para>[fernando] - Passage à -ruby-2.2.0. Corrige
+          <ulink url="&blfs-ticket-root;5982">#5982</ulink>.</para>
+        </listitem>
+        <listitem>
+          <para>[fernando] - wget-1.16.1: ajout de IO::Socket::SSL facultatif pour la suite de tests.</para>
+        </listitem>
+        <listitem>
+          <para>[fernando] - haveged-1.9.1: change URL.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
+    <listitem>
+      <para>26 Décembre 2014</para>
+      <itemizedlist>
+        <listitem>
+          <para>[fernando] - Passage à wicd-1.7.3. Corrige
+          <ulink url="&blfs-ticket-root;5977">#5977</ulink>.</para>
+        </listitem>
+        <listitem>
+          <para>[fernando] - OpenJDK-1.8.0.25:
+          retour des tests java cacerts.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
    <listitem>
+      <para>December 25th, 2014</para>
+      <itemizedlist>
+        <listitem>
+          <para>[fernando] - Reorganisation des dépendances facultatives de abiword-3.0.1.
+          Oubli de la mise à jour d'hier.</para>
+        </listitem>
+        <listitem>
+          <para>[igor] - Passage à ffmpeg-2.5.2. Corrige
+          <ulink url="&blfs-ticket-root;5978">#5978</ulink>.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
+    <listitem>
+      <para>24 Décembre 2014</para>
+      <itemizedlist>
+        <listitem>
+          <para>[igor] - Passage à gstreamer-1.4.5. Corrige
+          <ulink url="&blfs-ticket-root;5976">#5976</ulink>.</para>
+        </listitem>
+        <listitem>
+          <para>[fernando] - Passage à abiword-3.0.1. Corrige
+          <ulink url="&blfs-ticket-root;5979">#5979</ulink>.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
+   <listitem>
+      <para>23 Décembre 2014</para>
+      <itemizedlist>
+        <listitem>
+          <para>[bdubbs] - Archive bazaar. Corrige
+          <ulink url="&blfs-ticket-root;5973">#5973</ulink>.</para>
+        </listitem>
+        <listitem>
+          <para>[igor] - Passage à git-2.2.1. Corrige
+          <ulink url="&blfs-ticket-root;5961">#5961</ulink>.</para>
+        </listitem>
+        <listitem>
+          <para>[fernando] - Correction d'URLs: Libdvdread-5.0.0, Libdvdnav-5.0.1
+          et libxklavier-5.4.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+    <listitem>
+      <para>22 Decembre 2014</para>
+      <itemizedlist>
+        <listitem>
+          <para>[fernando] - Passage à libreoffice-4.3.5.2. Corrige
+          <ulink url="&blfs-ticket-root;5966">#5966</ulink>.</para>
+        </listitem>
+        <listitem>
+          <para>[fernando] - Passage à libxklavier-5.4. Corrige
+          <ulink url="&blfs-ticket-root;5975">#5975</ulink>.</para>
+        </listitem>
+        <listitem>
+          <para>[fernando] - Passage à libvdpau-0.9. Corrige
+          <ulink url="&blfs-ticket-root;5972">#5972</ulink>.</para>
+        </listitem>
+        <listitem>
+          <para>[fernando] - Passage à ntp-4.2.8. Corrige
+          <ulink url="&blfs-ticket-root;5971">#5971</ulink>.</para>
+        </listitem>
+        <listitem>
+          <para>[fernando] - mplayer-2014-12-19: utilisation de semi-colon pour séparer
+          les 'Dépendances facultatives' et clarification.</para>
+        </listitem>
+        <listitem>
+          <para>[fernando] - inkscape-0.48.5: utilisation du sed d'Armin pour rempalcer le sed
+          basé sur celui de Fernando dans le correctif d'Armin, utilisé pour remplacemer le correctif
+          d'Armin.</para>
+        </listitem>
+        <listitem>
+          <para>[pierre] - Passage à php-5.6.4. Corrige
+          <ulink url="&blfs-ticket-root;5963">#5963</ulink>.</para>
+        </listitem>
+        <listitem>
+          <para>[igor] - Passage à xorg-server-1.16.3. Corrige
+          <ulink url="&blfs-ticket-root;5974">#5974</ulink>.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+   <listitem>
+      <para>21 Décembre 2014</para>
+      <itemizedlist>
+        <listitem>
+          <para>[fernando] - Passage à postgresql-9.4.0. Corrige
+          <ulink url="&blfs-ticket-root;5964">#5964</ulink>.</para>
+        </listitem>
+        <listitem>
+          <para>[fernando] - Passage à mercurial-3.2.3. Corrige
+          <ulink url="&blfs-ticket-root;5962">#5962</ulink>.</para>
+        </listitem>
+        <listitem>
+          <para>[fernando] - Correction de la construction de  Inkscape-0.48.5 avec poppler-0.29.0.
+          Remplacement du correctif  gc par un sed.</para>
+        </listitem>
+        <listitem>
+          <para>[fernando] - Passage à udisks-2.1.4. Corrige
+          <ulink url="&blfs-ticket-root;5960">#5960</ulink>.</para>
+        </listitem>
+        <listitem>
+          <para>[igor] - Passage à elfutils-0.161. Corrige
+          <ulink url="&blfs-ticket-root;5968">#5968</ulink>.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
+
+
+   <listitem>
       <para>20 Décembre 2014</para>
       <itemizedlist>
+       <listitem>
+          <para>[fernando] - Passage à network-manager-applet-1.0.0. Corrige
+          <ulink url="&blfs-ticket-root;5965">#5965</ulink>.</para>
+        </listitem>
         <listitem>
+          <para>[fernando] - Passage à NetworkManager-1.0.0. Corrige
+          <ulink url="&blfs-ticket-root;5969">#5969</ulink>.</para>
+        </listitem>
+
+        <listitem>
           <para>[fernando] - Passage à mplayer-2014-12-19. Utilisation d'images
           suggérés par Armin. corrige
           <ulink url="&blfs-ticket-root;5967">#5967</ulink>.</para>

Modified: trunk/blfs/multimedia/videoutils/mplayer.xml
===================================================================
--- trunk/blfs/multimedia/videoutils/mplayer.xml	2014-12-29 12:36:07 UTC (rev 6712)
+++ trunk/blfs/multimedia/videoutils/mplayer.xml	2014-12-30 12:13:38 UTC (rev 6713)
@@ -177,8 +177,8 @@
       <xref linkend="freetype2"/>,
       <xref linkend="fribidi"/>,
       <xref linkend="gnutls"/>,
-      <xref linkend="openssl"/>, et
-      <xref linkend="opus"/>,
+      <xref linkend="openssl"/>,
+      <xref linkend="opus"/> et
       <xref linkend="unrar"/>;
       <xref linkend="libxslt"/>,
       <xref linkend="DocBook"/> et

Modified: trunk/blfs/networking/mailnews/mailx.xml
===================================================================
--- trunk/blfs/networking/mailnews/mailx.xml	2014-12-29 12:36:07 UTC (rev 6712)
+++ trunk/blfs/networking/mailnews/mailx.xml	2014-12-30 12:13:38 UTC (rev 6713)
@@ -59,8 +59,8 @@
     <itemizedlist spacing='compact'>
       <listitem>
         <para>Correctif requis : <ulink
-        url="&patch-root;/mailx-&mailx-version;-openssl_1.0.0_build_fix-1.patch"/>
-        (si vous voulez lier ce paquet à
+        url="&patch-root;/heirloom-mailx-&mailx-version;-fixes-1.patch"/>
+        </para>
         <application>openssl</application>)</para>
       </listitem>
     </itemizedlist>

Modified: trunk/blfs/networking/mailnews/mutt.xml
===================================================================
--- trunk/blfs/networking/mailnews/mutt.xml	2014-12-29 12:36:07 UTC (rev 6712)
+++ trunk/blfs/networking/mailnews/mutt.xml	2014-12-30 12:13:38 UTC (rev 6713)
@@ -47,6 +47,15 @@
         <para>Estimation du temps de construction : &mutt-time;</para>
       </listitem>
     </itemizedlist>
+
+    <bridgehead renderas="sect3">Téléchargements supplémentaires</bridgehead>
+    <itemizedlist spacing='compact'>
+      <listitem>
+        <para>Correctif requis: <ulink
+        url="&patch-root;/mutt-&mutt-version;-upstream_fixes-1.patch"/>
+        </para>
+      </listitem>
+    </itemizedlist>
     <bridgehead renderas="sect3">Dépendances de Mutt</bridgehead>
     <bridgehead renderas="sect4">Facultatives</bridgehead>
     <para role="optional">

Modified: trunk/blfs/networking/netprogs/wget.xml
===================================================================
--- trunk/blfs/networking/netprogs/wget.xml	2014-12-29 12:36:07 UTC (rev 6712)
+++ trunk/blfs/networking/netprogs/wget.xml	2014-12-30 12:13:38 UTC (rev 6713)
@@ -56,8 +56,10 @@
     <bridgehead renderas="sect4">Facultatives</bridgehead>
     <para role="optional">
     <xref linkend="libidn"/>,
-    <xref linkend="pcre"/>,
-    <xref linkend="perl-lwp"/> (requis pour la majorité de la suite de tests) 
+      <xref linkend="pcre"/>;
+      <xref linkend="perl-lwp"/> avec
+      <ulink url="http://search.cpan.org/~behroozi/IO-Socket-SSL/">IO::Socket::SSL</ulink>
+      (requis poru la suite de tests);
       <xref linkend="valgrind"/> (facultative pour la suite de tests, mais des échecs sont introduits),
     <ulink url="http://www.inet.no/dante/">Dante</ulink> et
       <ulink url="https://github.com/rockdaboot/libpsl/">libpsl</ulink></para>

Modified: trunk/blfs/networking/textweb/links.xml
===================================================================
--- trunk/blfs/networking/textweb/links.xml	2014-12-29 12:36:07 UTC (rev 6712)
+++ trunk/blfs/networking/textweb/links.xml	2014-12-30 12:13:38 UTC (rev 6713)
@@ -51,13 +51,12 @@
     
     <bridgehead renderas="sect3">Dépendances de Links</bridgehead>
     <bridgehead renderas="sect4">Recommandés</bridgehead>
-    <para role="recommended"><xref linkend="gpm"/> (si le support pour la souris
-    est désiré) et
+    <para role="recommended">
     <xref linkend="openssl"/></para>
     
     <bridgehead renderas="sect4">Facultatives</bridgehead>
-    <para role="optional">Le support pour le mode graphique exige au moins un
-    <xref linkend="gpm"/> (pour être utilisé dans une console basée sur framebuffer),
+    <para role="optional">Le mode graphique exige au moins un
+    <xref linkend="gpm"/> (le support de la souris pour être utilisé dans une console basée sur framebuffer),
     <ulink url="http://www.svgalib.org/">SVGAlib</ulink>,
     
     <ulink url="http://www.directfb.org/">DirectFB</ulink>, et

Deleted: trunk/blfs/traduc/commits/r15266.txt
===================================================================
--- trunk/blfs/traduc/commits/r15266.txt	2014-12-29 12:36:07 UTC (rev 6712)
+++ trunk/blfs/traduc/commits/r15266.txt	2014-12-30 12:13:38 UTC (rev 6713)
@@ -1,84 +0,0 @@
-Révision 15266
-
-fichiers modifiés :
-   networking/netprogs/wget.xml
-   postlfs/security/haveged.xml
-   general.ent
-   packages.ent
-   general/prog/ruby.xml
-   introduction/welcome/changelog.xml
-
-Log :
-haveged-1.9.1: change URL. wget-1.16.1: include IO::Socket::SSL optional for the test suite. Update to -ruby-2.2.0.
-
-Le robot a traité 50 % du commit anglais
-Index: general/prog/ruby.xml
-===================================================================
---- general/prog/ruby.xml	(révision 15265)
-+++ general/prog/ruby.xml	(révision 15266)
-@@ -151,15 +151,13 @@
- 
-       <seglistitem>
-         <seg>
--erb, gem, irb, rake, rdoc, ri, ruby, and testrb
-+          erb, gem, irb, rake, rdoc, ri, and ruby
-         </seg>
-         <seg>
--libruby.so, libruby-static.a, and numerous modules located in the
--<filename class="directory">/usr/lib/ruby</filename> hierarchy.
-+          libruby.so and libruby-static.a
-         </seg>
-         <seg>
--<!--          /usr/include/ruby-&ruby-version;,-->
--/usr/include/ruby-2.1.0,
-+          /usr/include/ruby-&ruby-version;
-           /usr/lib/ruby,
-           /usr/share/doc/ruby-&ruby-version; and
-           /usr/share/ri
-
-Index: introduction/welcome/changelog.xml
-===================================================================
---- introduction/welcome/changelog.xml	(révision 15265)
-+++ introduction/welcome/changelog.xml	(révision 15266)
-@@ -45,6 +45,23 @@
- -->
- 
-     <listitem>
-+      <para>December 27th, 2014</para>
-+      <itemizedlist>
-+        <listitem>
-+          <para>[fernando] - Update to -ruby-2.2.0. Fixes
-+          <ulink url="&blfs-ticket-root;5982">#5982</ulink>.</para>
-+        </listitem>
-+        <listitem>
-+          <para>[fernando] - wget-1.16.1: include IO::Socket::SSL optional
-+          for the test suite.</para>
-+        </listitem>
-+        <listitem>
-+          <para>[fernando] - haveged-1.9.1: change URL.</para>
-+        </listitem>
-+      </itemizedlist>
-+    </listitem>
-+    <listitem>
-       <para>December 26th, 2014</para>
-       <itemizedlist>
-         <listitem>
-
-Index: networking/netprogs/wget.xml
-===================================================================
---- networking/netprogs/wget.xml	(révision 15265)
-+++ networking/netprogs/wget.xml	(révision 15266)
-@@ -82,8 +82,10 @@
-     <bridgehead renderas="sect4">Optional</bridgehead>
-     <para role="optional">
-       <xref linkend="libidn"/>,
--<xref linkend="pcre"/>,
--<xref linkend="perl-lwp"/> (required for the majority of the test suite),
-+      <xref linkend="pcre"/>;
-+      <xref linkend="perl-lwp"/> with
-+      <ulink url="http://search.cpan.org/~behroozi/IO-Socket-SSL/">IO::Socket::SSL</ulink>
-+      (required for the test suite);
-       <xref linkend="valgrind"/> (optional for the test suite, but failures are
-       introduced),
-       <ulink url="http://www.inet.no/dante/">Dante</ulink>, and
-

Deleted: trunk/blfs/traduc/commits/r15267.txt
===================================================================
--- trunk/blfs/traduc/commits/r15267.txt	2014-12-29 12:36:07 UTC (rev 6712)
+++ trunk/blfs/traduc/commits/r15267.txt	2014-12-30 12:13:38 UTC (rev 6713)
@@ -1,82 +0,0 @@
-Révision 15267
-
-fichiers modifiés :
-   introduction/welcome/changelog.xml
-   networking/mailnews/mailx.xml
-   packages.ent
-
-Log :
-Heirloom-mailx-12.5.
-
-Le robot a traité 25 % du commit anglais
-Index: introduction/welcome/changelog.xml
-===================================================================
---- introduction/welcome/changelog.xml	(révision 15266)
-+++ introduction/welcome/changelog.xml	(révision 15267)
-@@ -48,6 +48,9 @@
-       <para>December 27th, 2014</para>
-       <itemizedlist>
-         <listitem>
-+          <para>[ken] - Update to heirloom-mailx-12.5.</para>
-+        </listitem>
-+        <listitem>
-           <para>[fernando] - Update to -ruby-2.2.0. Fixes
-           <ulink url="&blfs-ticket-root;5982">#5982</ulink>.</para>
-         </listitem>
-
-Index: networking/mailnews/mailx.xml
-===================================================================
---- networking/mailnews/mailx.xml	(révision 15266)
-+++ networking/mailnews/mailx.xml	(révision 15267)
-@@ -4,11 +4,14 @@
-   <!ENTITY % general-entities SYSTEM "../../general.ent">
-   %general-entities;
- 
-+  <!-- upstream is apparently still using CVS at sourceforge,
-+  but not making tarballs.  fedora have a script using CVS, but
-+  debian keep a tarball -->
-   <!ENTITY mailx-time          "less than 0.1 SBU">
- ]>
- 
-@@ -65,9 +68,8 @@
-     <itemizedlist spacing='compact'>
-       <listitem>
-         <para>Required patch: <ulink
--url="&patch-root;/mailx-&mailx-version;-openssl_1.0.0_build_fix-1.patch"/>
--(if you intend to link this package against
--<application>openssl</application>)</para>
-+        url="&patch-root;/heirloo-mailx-&mailx-version;-fixes-1.patch"/>
-+        </para>
-       </listitem>
-     </itemizedlist>
- 
-@@ -88,6 +90,8 @@
-   <sect2 role="installation">
-     <title>Installation of Heirloom mailx</title>
- 
-+   <!-- see r12697 for explanation, and still used by fedora even though it often
-+    does work with a parallel make -->
-     <note>
-       <para>
-         This package does not support parallel build.
-@@ -97,7 +101,7 @@
-     <para>Install <application>Heirloom mailx</application> by running the
-     following commands.</para>
- 
--<screen><userinput>patch -Np1 -i ../mailx-&mailx-version;-openssl_1.0.0_build_fix-1.patch &&
-+<screen><userinput>patch -Np1 -i ../heirloom-mailx-&mailx-version;-fixes-1.patch &&
- make SENDMAIL=/usr/sbin/sendmail -j1</userinput></screen>
- 
-     <para>This package does not come with a test suite.</para>
-@@ -107,8 +111,8 @@
- <screen role='root'><userinput>make PREFIX=/usr UCBINSTALL=/usr/bin/install install &&
- ln -v -sf mailx /usr/bin/mail &&
- ln -v -sf mailx /usr/bin/nail &&
--install -v -m755 -d /usr/share/doc/mailx-&mailx-version; &&
--install -v -m644 README mailx.1.html /usr/share/doc/mailx-&mailx-version;</userinput></screen>
-+install -v -m755 -d /usr/share/doc/heirloom-mailx-&mailx-version; &&
-+install -v -m644 README /usr/share/doc/heirloom-mailx-&mailx-version;</userinput></screen>
- 
-   </sect2>
- 
-

Deleted: trunk/blfs/traduc/commits/r15268.txt
===================================================================
--- trunk/blfs/traduc/commits/r15268.txt	2014-12-29 12:36:07 UTC (rev 6712)
+++ trunk/blfs/traduc/commits/r15268.txt	2014-12-30 12:13:38 UTC (rev 6713)
@@ -1,9 +0,0 @@
-Révision 15268
-
-fichiers modifiés :
-   xsoft/other/icedtea-web.xml
-
-Log :
-Update icedtea-web md5: the former one was for a pre-release tarball
-
-Le robot a traité 100 % du commit anglais

Deleted: trunk/blfs/traduc/commits/r15269.txt
===================================================================
--- trunk/blfs/traduc/commits/r15269.txt	2014-12-29 12:36:07 UTC (rev 6712)
+++ trunk/blfs/traduc/commits/r15269.txt	2014-12-30 12:13:38 UTC (rev 6713)
@@ -1,74 +0,0 @@
-Révision 15269
-
-fichiers modifiés :
-   introduction/welcome/changelog.xml
-   networking/mailnews/mutt.xml
-   networking/mailnews/mailx.xml
-
-Log :
-Fix typo in my mailx commit and expand changelog entry, patch mutt.
-
-Le robot a traité 1 % du commit anglais
-Index: introduction/welcome/changelog.xml
-===================================================================
---- introduction/welcome/changelog.xml	(révision 15268)
-+++ introduction/welcome/changelog.xml	(révision 15269)
-@@ -48,9 +48,12 @@
-       <para>December 27th, 2014</para>
-       <itemizedlist>
-         <listitem>
--<para>[ken] - Update to heirloom-mailx-12.5.</para>
-+          <para>[ken] - Security fix for mutt-1.5.23.</para>
-         </listitem>
-         <listitem>
-+          <para>[ken] - Update to heirloom-mailx-12.5 including security fix.</para>
-+        </listitem>
-+        <listitem>
-           <para>[fernando] - Update to -ruby-2.2.0. Fixes
-           <ulink url="&blfs-ticket-root;5982">#5982</ulink>.</para>
-         </listitem>
-
-Index: networking/mailnews/mailx.xml
-===================================================================
---- networking/mailnews/mailx.xml	(révision 15268)
-+++ networking/mailnews/mailx.xml	(révision 15269)
-@@ -68,7 +68,7 @@
-     <itemizedlist spacing='compact'>
-       <listitem>
-         <para>Required patch: <ulink
--url="&patch-root;/heirloo-mailx-&mailx-version;-fixes-1.patch"/>
-+        url="&patch-root;/heirloom-mailx-&mailx-version;-fixes-1.patch"/>
-         </para>
-       </listitem>
-     </itemizedlist>
-
-Index: networking/mailnews/mutt.xml
-===================================================================
---- networking/mailnews/mutt.xml	(révision 15268)
-+++ networking/mailnews/mutt.xml	(révision 15269)
-@@ -58,6 +58,15 @@
-       </listitem>
-     </itemizedlist>
- 
-+    <bridgehead renderas="sect3">Additional Downloads</bridgehead>
-+    <itemizedlist spacing='compact'>
-+      <listitem>
-+        <para>Required patch: <ulink
-+        url="&patch-root;/mutt-&mutt-version;-upstream_fixes-1.patch"/>
-+        </para>
-+      </listitem>
-+    </itemizedlist>
-     <bridgehead renderas="sect3">Mutt Dependencies</bridgehead>
- 
-     <bridgehead renderas="sect4">Optional</bridgehead>
-@@ -130,7 +139,8 @@
-     <para>Install <application>Mutt</application> by running the following
-     commands:</para>
- 
--<screen><userinput>./configure --prefix=/usr     \
-+<screen><userinput>patch -Np1 -i ../mutt-&mutt-version;-upstream_fixes-1.patch &&
-+./configure --prefix=/usr     \
-             --sysconfdir=/etc \
-             --with-docdir=/usr/share/doc/mutt-&mutt-version; \
-             --enable-pop      \
-

Deleted: trunk/blfs/traduc/commits/r15270.txt
===================================================================
--- trunk/blfs/traduc/commits/r15270.txt	2014-12-29 12:36:07 UTC (rev 6712)
+++ trunk/blfs/traduc/commits/r15270.txt	2014-12-30 12:13:38 UTC (rev 6713)
@@ -1,9 +0,0 @@
-Révision 15270
-
-fichiers modifiés :
-   general/prog/openjdk.xml
-
-Log :
-Clean up white spaces.
-
-Le robot a traité 100 % du commit anglais

Deleted: trunk/blfs/traduc/commits/r15271.txt
===================================================================
--- trunk/blfs/traduc/commits/r15271.txt	2014-12-29 12:36:07 UTC (rev 6712)
+++ trunk/blfs/traduc/commits/r15271.txt	2014-12-30 12:13:38 UTC (rev 6713)
@@ -1,26 +0,0 @@
-Révision 15271
-
-fichiers modifiés :
-   multimedia/videoutils/mplayer.xml
-   general.ent
-
-Log :
-mplayer-2014-12-19: typo.
-
-Le robot a traité 55 % du commit anglais
-Index: multimedia/videoutils/mplayer.xml
-===================================================================
---- multimedia/videoutils/mplayer.xml	(révision 15270)
-+++ multimedia/videoutils/mplayer.xml	(révision 15271)
-@@ -240,8 +240,8 @@
-       <xref linkend="freetype2"/>,
-       <xref linkend="fribidi"/>,
-       <xref linkend="gnutls"/>,
--<xref linkend="openssl"/>, and
--<xref linkend="opus"/>,
-+      <xref linkend="openssl"/>,
-+      <xref linkend="opus"/>, and
-       <xref linkend="unrar"/>;
-       <xref linkend="libxslt"/>,
-       <xref linkend="DocBook"/> and
-

Deleted: trunk/blfs/traduc/commits/r15272.txt
===================================================================
--- trunk/blfs/traduc/commits/r15272.txt	2014-12-29 12:36:07 UTC (rev 6712)
+++ trunk/blfs/traduc/commits/r15272.txt	2014-12-30 12:13:38 UTC (rev 6713)
@@ -1,30 +0,0 @@
-Révision 15272
-
-fichiers modifiés :
-   introduction/welcome/changelog.xml
-   server/mail/exim.xml
-
-Log :
-exim-4.84: change URL.
-
-Le robot a traité 48 % du commit anglais
-Index: introduction/welcome/changelog.xml
-===================================================================
---- introduction/welcome/changelog.xml	(révision 15271)
-+++ introduction/welcome/changelog.xml	(révision 15272)
-@@ -45,6 +45,15 @@
- -->
- 
-     <listitem>
-+      <para>December 28th, 2014</para>
-+      <itemizedlist>
-+        <listitem>
-+          <para>[fernando] - exim-4.84: change URL.</para>
-+        </listitem>
-+      </itemizedlist>
-+    </listitem>
-+    <listitem>
-       <para>December 27th, 2014</para>
-       <itemizedlist>
-         <listitem>
-

Deleted: trunk/blfs/traduc/commits/r15273.txt
===================================================================
--- trunk/blfs/traduc/commits/r15273.txt	2014-12-29 12:36:07 UTC (rev 6712)
+++ trunk/blfs/traduc/commits/r15273.txt	2014-12-30 12:13:38 UTC (rev 6713)
@@ -1,52 +0,0 @@
-Révision 15273
-
-fichiers modifiés :
-   packages.ent
-   introduction/welcome/changelog.xml
-   networking/textweb/links.xml
-
-Log :
-Update to links-2.9.
-
-Le robot a traité 77 % du commit anglais
-Index: introduction/welcome/changelog.xml
-===================================================================
---- introduction/welcome/changelog.xml	(révision 15272)
-+++ introduction/welcome/changelog.xml	(révision 15273)
-@@ -48,6 +48,10 @@
-       <para>December 28th, 2014</para>
-       <itemizedlist>
-         <listitem>
-+          <para>[igor] - Update to links-2.9. Fixes
-+          <ulink url="&blfs-ticket-root;5980">#5980</ulink>.</para>
-+        </listitem>
-+        <listitem>
-           <para>[fernando] - exim-4.84: change URL.</para>
-         </listitem>
-       </itemizedlist>
-
-Index: networking/textweb/links.xml
-===================================================================
---- networking/textweb/links.xml	(révision 15272)
-+++ networking/textweb/links.xml	(révision 15273)
-@@ -58,67 +58,15 @@
-     <bridgehead renderas="sect3">Links Dependencies</bridgehead>
- 
-     <bridgehead renderas="sect4">Recommended</bridgehead>
--<para role="recommended"><xref linkend="gpm"/> (if mouse support is
--desired) and
--<xref linkend="openssl"/></para>
--<!-- pcre was used in previous versions only, for javascript
--<xref linkend="pcre"/>
---->
-+    <para role="recommended"><xref linkend="openssl"/></para>
- 
-     <bridgehead renderas="sect4">Optional</bridgehead>
--<para role="optional">Support for graphical mode requires at least one of
--<xref linkend="gpm"/> (to be used with a framebuffer-based console),
-+    <para role="optional">Graphics mode requires at least one of
-+    <xref linkend="gpm"/> (mouse support to be used with a framebuffer-based console),
-     <ulink url="http://www.svgalib.org/">SVGAlib</ulink>,
-     <ulink url="http://www.directfb.org/">DirectFB</ulink>, and
-     <xref linkend="x-window-system"/></para>
-

Deleted: trunk/blfs/traduc/commits/r15274.txt
===================================================================
--- trunk/blfs/traduc/commits/r15274.txt	2014-12-29 12:36:07 UTC (rev 6712)
+++ trunk/blfs/traduc/commits/r15274.txt	2014-12-30 12:13:38 UTC (rev 6713)
@@ -1,185 +0,0 @@
-Révision 15274
-
-fichiers modifiés :
-   introduction/welcome/changelog.xml
-   packages.ent
-   general/prog/doxygen.xml
-   general/prog/ruby.xml
-   general/genutils/graphviz.xml
-
-Log :
-Update to doxygen-1.8.9. ruby-2.2.0: fix build of capi docs and statistics to make explicit docs part. graphviz-2.38.0: fix build with ruby-2.2.0.
-
-Le robot a traité 27 % du commit anglais
-Index: general/genutils/graphviz.xml
-===================================================================
---- general/genutils/graphviz.xml	(révision 15273)
-+++ general/genutils/graphviz.xml	(révision 15274)
-@@ -133,11 +133,13 @@
-       commands:
-     </para>
- 
--<screen><userinput>./configure --prefix=/usr &&
-+<screen><userinput>sed "s:ruby-1.9:ruby-2.2:g" -i configure &&
-+./configure --prefix=/usr &&
- make</userinput></screen>
- 
-     <para>
-@@ -159,6 +161,17 @@
- 
-   </sect2>
- 
-+  <sect2 role="commands">
-+    <title>Command Explanations</title>
-+    <para>
-+      <command>sed "s:ruby-1.9:ruby-2.2:g" -i configure</command>: Use this
-+      command, if ruby-2.2.0 is installed and you wish
-+      <application>Graphviz</application> built with support for it.
-+    </para>
-+  </sect2>
-   <sect2 role="configuration">
-     <title>Configuring Graphviz</title>
- 
-
-Index: general/prog/doxygen.xml
-===================================================================
---- general/prog/doxygen.xml	(révision 15273)
-+++ general/prog/doxygen.xml	(révision 15274)
-@@ -92,9 +92,11 @@
-     <para role="optional">
-       <xref linkend="graphviz"/>,
-       <xref linkend="gs"/>,
--<xref linkend="python2"/>,
--<xref linkend="qt4"/> (for doxywizard) and
--<xref linkend="texlive"/>
-+      <xref linkend="llvm"/> (with clang),
-+      <xref linkend="python2"/> or <xref linkend="python3"/>,
-+      <xref linkend="qt4"/> (for doxywizard),
-+      <xref linkend="texlive"/>, and
-+      <xref linkend="xapian"/> (for doxyindexer)
-     </para>
- 
-     <para condition="html" role="usernotes">User Notes:
-@@ -142,15 +144,25 @@
-     <title>Command Explanations</title>
- 
-     <para>
--<option>--with-doxywizard</option>: Use this parameter if
--<application>Qt4</application> is installed and you wish to build the
--GUI front-end. If both <application>Qt4</application> and
--<application>Qt5</application> are installed, use
--<command>source setqt4</command>. If <application>Qt4</application> is
--installed in <filename class="directory">/opt</filename>, issue
--<command>export QTDIR=$QT4DIR</command>.
-+      <option>--with-doxywizard</option>: Use this switch if
-+      <application>Qt4</application> is installed and you wish to build the GUI
-+      front-end. If both <application>Qt4</application> and
-+      <application>Qt5</application> are installed, use <command>source
-+      setqt4</command>. If <application>Qt4</application> is installed in
-+      <filename class="directory">/opt</filename>, issue <command>export
-+      QTDIR=$QT4DIR</command>.
-     </para>
- 
-+    <para>
-+      <option>--with-doxysearch</option>: Use this switch if
-+      <application>xapian</application> is installed and you wish to build
-+      external search tools (doxysearch and doxyindexer).
-+    </para>
-+    <para>
-+      <option>--with-libclang</option>: Use this switch if
-+      <application>llvm</application> with <application>clang</application> are
-+      installed, to add support for libclang parsing.</para>
-   </sect2>
- 
-   <sect2 role="configuration">
-@@ -223,6 +236,34 @@
-         </listitem>
-       </varlistentry>
- 
-+      <varlistentry id="doxyindexer">
-+        <term><command>doxyindexer</command></term>
-+        <listitem>
-+          <para>
-+            generates a search index called <filename>doxysearch.db</filename>
-+            from one or more search data files produced by
-+            <command>doxygen</command>. See, e.g. <ulink
-+            url="http://www.stack.nl/~dimitri/doxygen/manual/extsearch.html"/>.
-+          </para>
-+          <indexterm zone="doxygen doxyindexer">
-+            <primary sortas="b-doxyindexer">doxyindexer</primary>
-+          </indexterm>
-+        </listitem>
-+      </varlistentry>
-+      <varlistentry id="doxysearch.cgi">
-+        <term><command>doxysearch.cgi</command></term>
-+        <listitem>
-+          <para>
-+            is a CGI program to search the data indexed by
-+            <command>doxyindexer</command>.
-+          </para>
-+          <indexterm zone="doxygen doxysearch.cgi">
-+            <primary sortas="b-doxysearch.cgi">doxysearch.cgi</primary>
-+          </indexterm>
-+        </listitem>
-+      </varlistentry>
-     </variablelist>
- 
-   </sect2>
-
-Index: general/prog/ruby.xml
-===================================================================
---- general/prog/ruby.xml	(révision 15273)
-+++ general/prog/ruby.xml	(révision 15274)
-@@ -96,15 +96,29 @@
- 
-     <para>
-       Install <application>Ruby</application> by running the following
--commands:
-+      command:
-     </para>
- 
- <screen><userinput>./configure --prefix=/usr   \
-             --enable-shared \
----docdir=/usr/share/doc/ruby-&ruby-version; &&
--make</userinput></screen>
-+            --docdir=/usr/share/doc/ruby-&ruby-version;</userinput></screen>
- 
-     <para>
-+      Optionally, build the CAPI documents by running the following
-+      commands:
-+    </para>
-+<screen><userinput>cp -v template/Doxyfile.tmpl Doxyfile &&
-+doxygen</userinput></screen>
-+    <para>
-+      Compile and link <application>Ruby</application> by running the following
-+      command:
-+    </para>
-+<screen><userinput>make</userinput></screen>
-+    <para>
-       To test the results, issue: <command>make test</command>.
-     </para>
- 
-
-Index: introduction/welcome/changelog.xml
-===================================================================
---- introduction/welcome/changelog.xml	(révision 15273)
-+++ introduction/welcome/changelog.xml	(révision 15274)
-@@ -48,6 +48,17 @@
-       <para>December 28th, 2014</para>
-       <itemizedlist>
-         <listitem>
-+          <para>[fernando] - ruby-2.2.0: fix build of capi docs and statistics
-+          to make explicit docs part.</para>
-+        </listitem>
-+        <listitem>
-+          <para>[fernando] - graphviz-2.38.0: fix build with ruby-2.2.0.</para>
-+        </listitem>
-+        <listitem>
-+          <para>[fernando] - Update to doxygen-1.8.9. Fixes
-+          <ulink url="&blfs-ticket-root;5983">#5983</ulink>.</para>
-+        </listitem>
-+        <listitem>
-           <para>[igor] - Update to links-2.9. Fixes
-           <ulink url="&blfs-ticket-root;5980">#5980</ulink>.</para>
-         </listitem>
-



More information about the lfs-traducfr mailing list