[lfs-fr] r6898 - in trunk/blfs: general/graphlib general/prog kde kde/add kde/core kde/plasma5 multimedia/libdriv networking/netutils server/databases traduc/commits x/lib

myou72 at orange.fr myou72 at orange.fr
Lun 29 Juin 13:24:56 PDT 2015


Author: myou72
Date: 2015-06-29 13:24:56 -0700 (Mon, 29 Jun 2015)
New Revision: 6898

Added:
   trunk/blfs/kde/plasma5/
   trunk/blfs/kde/plasma5/plasma5.xml
Removed:
   trunk/blfs/traduc/commits/r16160.txt
   trunk/blfs/traduc/commits/r16161.txt
   trunk/blfs/traduc/commits/r16162.txt
   trunk/blfs/traduc/commits/r16163.txt
   trunk/blfs/traduc/commits/r16164.txt
Modified:
   trunk/blfs/general/graphlib/poppler.xml
   trunk/blfs/general/prog/cvs.xml
   trunk/blfs/general/prog/tcl.xml
   trunk/blfs/kde/add/add.xml
   trunk/blfs/kde/core/attica.xml
   trunk/blfs/kde/core/config.xml
   trunk/blfs/kde/core/core.xml
   trunk/blfs/kde/core/oxygen-icons.xml
   trunk/blfs/kde/core/pre-install-config.xml
   trunk/blfs/kde/kde.xml
   trunk/blfs/multimedia/libdriv/pulseaudio.xml
   trunk/blfs/networking/netutils/wicd.xml
   trunk/blfs/server/databases/db.xml
   trunk/blfs/x/lib/qt4.xml
   trunk/blfs/x/lib/qt5.xml
Log:
16164

Modified: trunk/blfs/general/graphlib/poppler.xml
===================================================================
--- trunk/blfs/general/graphlib/poppler.xml	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/general/graphlib/poppler.xml	2015-06-29 20:24:56 UTC (rev 6898)
@@ -113,22 +113,20 @@
 </screen>
     <note>
       <para>
-      Ce paquet peut être construit facultativement avec le support pour soit les bibliothèques
-      Qt4 ou soit Qt5, mais il le construira seulement pour l'une d'elle. si vous avez les deux
-      versions de Qt d'installées, vous devez spécifier laquelle utiliser avant
-      d'exécuter la commande <command>configure</command> donnée avant. Utiliser cette commande
-      pour lier à Qt4.
+      Ce paquet peut être construit facultativement avec le support pour une seule version de 
+      Qt4 ou Qt5. si vous avez qu'une version, aucune modification n'est nécessaire. Si les deux
+      versions de Qt sont installées, et que vous voulez le support pour une seule, avant d'exécuter
+      la commande <command>configure</command> donnée avant. Utiliser cette commande
+      pour sélectionner Qt4.
       
 <screen>
 <userinput>source /usr/bin/setqt4</userinput>
 </screen>
-    ou pour utiliser Qt5:
+    ou pour sélectionner Qt5:
       
 <screen>
 <userinput>source /usr/bin/setqt5</userinput>
 </screen>
-      si vous voulez que <application>Poppler</application> soit lié aux deux versions de Qt, 
-      vous devez le construire deux fois.
     </para></note>
  
     <para>
@@ -171,6 +169,14 @@
   </sect2>
   <sect2 role="commands">
     <title>Explication des commandes</title>
+    <para>
+     <envar>MOCQT4=$QT4DIR/bin/moc</envar> et
+      <envar>MOCQT5=$QT5DIR/bin/moc</envar>:
+      Ces variables d'environement son necessaire, pour lier avec les deux versions de Qt, si les deux
+      sont installées. Si une seule version de Qt est installée, ou si vous voulez lier à une seule version,
+      vous pouvez les effacer, car c'est pas utile.
+    </para>
+
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
       href="../../xincludes/static-libraries.xml"/>
     <para>

Modified: trunk/blfs/general/prog/cvs.xml
===================================================================
--- trunk/blfs/general/prog/cvs.xml	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/general/prog/cvs.xml	2015-06-29 20:24:56 UTC (rev 6898)
@@ -127,19 +127,7 @@
 <screen>
 <userinput>make -C doc html txt</userinput>
 </screen>
-    <para>Pour tester les résultats, lancez : <command>make check</command>. Ceci prendra
-    beaucoup de temps. Si vous n'avez pas configuré <command>rsh</command> pour l'accès
-    au hôte sur lequel vous êtes en train de construire, (ou si vous n'avez pas passé
-    le paramètre <option>--with-rsh=</option> au script <command>configure</command>,
-    il se peut que certains tests échouent. Si vous avez passé le paramètre
-    <option>--with-rsh=ssh</option> pour activer <command>ssh</command> comme 
-    programme de shell distant par défaut, vous devrez faire la
-    commande suivante afin que le test se termine sans échec :</para>
-<screen>
-<userinput>sed -e 's/rsh};/ssh};/' \
-    -e 's/g=rw,o=r$/g=r,o=r/' \
-    -i src/sanity.sh</userinput>
-</screen>
+   <para>Ce paquet n'a pas de suite de tests valide.</para>
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 <screen role='root'>
 <userinput>make install &&

Modified: trunk/blfs/general/prog/tcl.xml
===================================================================
--- trunk/blfs/general/prog/tcl.xml	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/general/prog/tcl.xml	2015-06-29 20:24:56 UTC (rev 6898)
@@ -121,10 +121,6 @@
   </sect2>
   <sect2 role="commands">
     <title>Explication des commandes</title>
-     <para>
-      <option>--without-tzdata</option>: Ce paramètre empêche l'installation des
-      données de timezone fournies qui sont plus anciennes que celles présentes dans LFS.
-    </para>
     <para>
       <parameter>$([ $(uname -m) = x86_64 ] && echo
       --enable-64bit)</parameter> : Ce paramètre est utilisé pour activer le support 64 bit

Modified: trunk/blfs/kde/add/add.xml
===================================================================
--- trunk/blfs/kde/add/add.xml	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/kde/add/add.xml	2015-06-29 20:24:56 UTC (rev 6898)
@@ -6,7 +6,7 @@
 ]>
 <chapter id="kde-add">
   <?dbhtml filename="add.html"?>
-  <title>Paquets Supplémentaires de KDE</title>
+  <title>Paquets Supplémentaires de KDE4</title>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="konsole.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="kate.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="ark.xml"/>

Modified: trunk/blfs/kde/core/attica.xml
===================================================================
--- trunk/blfs/kde/core/attica.xml	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/kde/core/attica.xml	2015-06-29 20:24:56 UTC (rev 6898)
@@ -52,12 +52,6 @@
     <xref linkend="qt4"/> et
     <xref linkend="cmake"/>
     </para>
-    <bridgehead renderas="sect4">Facultatives</bridgehead>
-    <para role="optional">
-      <xref linkend="qt5"/> (demande
-      <ulink url="http://quickgit.kde.org/index.php?p=extra-cmake-modules.git">
-      extra-cmake-modules</ulink>)
-    </para>
     <para condition="html" role="usernotes">Notes utilisateur :
     <ulink url="&blfs-wiki;/attica"/></para>
   </sect2>

Modified: trunk/blfs/kde/core/config.xml
===================================================================
--- trunk/blfs/kde/core/config.xml	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/kde/core/config.xml	2015-06-29 20:24:56 UTC (rev 6898)
@@ -4,13 +4,13 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 ]>
-<sect1 id="kde-core-config" xreflabel="Démarrage de KDE">
+<sect1 id="kde-core-config" xreflabel="Démarrage de KDE4">
   <?dbhtml filename="config.html"?>
   <sect1info>
     <othername>$LastChangedBy : rthomsen $</othername>
     <date>$Date : 2012-04-15 19:19:58 +0200 (Sun, 15 Apr 2012) $</date>
   </sect1info>
-  <title>Démarrage de KDE</title>
+  <title>Démarrage de KDE4</title>
   
   <bridgehead renderas="sect3">dépendances de démarrage de KDE</bridgehead>
   <bridgehead renderas="sect4">Facultatives</bridgehead>
@@ -19,11 +19,11 @@
   </para>
   <para>Après avoir installé <application>Kde-workspace</application>, une
   première étape importante a été franchie. Maintenant, vous devez configurer 
-  votre système pour démarrer KDE.</para>
+  votre système pour démarrer KDE4.</para>
   
   <sect2 role="content">
-  <title>Démarrage de KDE à partir de l'invite de commande</title>
- <para>Pour démarrer <application>KDE</application> à partir de l'invite de
+  <title>Démarrage de KDE4 à partir de l'invite de commande</title>
+ <para>Pour démarrer <application>KDE4</application> à partir de l'invite de
  commande, vous devrez modifier votre fichier 
  <filename>.xinitrc</filename> :</para>
     
@@ -38,17 +38,17 @@
     supprimez 
     <userinput>ck-launch-session</userinput>.</para></note>
     
-    <para>Vous pouvez maintenant démarrer KDE en utilisant la commande
+    <para>Vous pouvez maintenant démarrer KDE4 en utilisant la commande
     <command>startx</command>.</para>
       
     </sect2>
     
     <sect2 role="content">
-    <title>Démarrage de KDE à l'amorçage</title>
+    <title>Démarrage de KDE4 à l'amorçage</title>
     
-    <para>KDE est fourni avec une interface de connexion graphique appelée
-    KDM (le <foreignphrase>KDE Display Manager</foreignphrase> (gestionnaire
-    d'affichage KDE)) qui offre une connexion graphique personnalisable au 
+    <para>KDE4 est fourni avec une interface de connexion graphique appelée
+    KDM (le <foreignphrase>KDE4 Display Manager</foreignphrase> (gestionnaire
+    d'affichage KDE4)) qui offre une connexion graphique personnalisable au 
     démarrage. Pour utiliser KDM, vous devez éditer votre fichier
     <filename>/etc/inittab</filename> (en tant qu'utilisateur
     <systemitem class="username">root</systemitem>). Tout d'abord, réglez
@@ -64,7 +64,7 @@
 <userinput>sed -i 's#id:3:initdefault:#id:5:initdefault:#' /etc/inittab</userinput>
 </screen>
     <para>Vous pouvez maintenant redémarrer votre système et vous verrez l'écran
-	de connexion KDE.</para>
+	de connexion KDE4.</para>
   
   </sect2>
   
@@ -75,14 +75,14 @@
 <ulink url="&kde-download-http;applications/&kde-apps-version;/src/kde-l10n/">
          &kde-download-http;applications/&kde-apps-version;/src/kde-l10n/</ulink>.
     Regardez <xref linkend="kde-add-pkgs"/> pour les instructions de construction. Si vous êtes
-    dans une session KDE quand vous installez une nouvelle langue et configurez KDE pour l'utiliser, 
+    dans une session KDE4 quand vous installez une nouvelle langue et configurez KDE4 pour l'utiliser, 
     la session doit être redémarrée, pour voir les effets.
     </para>
   </sect2>
   <sect2 role="content">
-    <title>Installation de paquets KDE supplémentaires</title>
+    <title>Installation de paquets KDE4 supplémentaires</title>
     <para>Tous les paquets suivants peuvent être construits alors que 
-    <application>KDE</application> est actif et fonctionne, mais souvenez-vous
+    <application>KDE4</application> est actif et fonctionne, mais souvenez-vous
     de garder le réglage de <envar>&kde-dir;</envar> et <envar>&qt4-dir;</envar>.</para>
   </sect2>
    

Modified: trunk/blfs/kde/core/core.xml
===================================================================
--- trunk/blfs/kde/core/core.xml	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/kde/core/core.xml	2015-06-29 20:24:56 UTC (rev 6898)
@@ -6,7 +6,8 @@
 ]>
 <chapter id="kde4-core">
   <?dbhtml filename="core.html"?>
-  <title>Le coeur de KDE</title>
+  <title>Le coeur de KDE4</title>
+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="pre-install-config.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="automoc4.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="phonon.xml"/>
 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="phonon-backend-gstreamer.xml"/>

Modified: trunk/blfs/kde/core/oxygen-icons.xml
===================================================================
--- trunk/blfs/kde/core/oxygen-icons.xml	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/kde/core/oxygen-icons.xml	2015-06-29 20:24:56 UTC (rev 6898)
@@ -58,6 +58,9 @@
     <title>Installation de Oxygen-icons</title>
     <para>Installez <application>Oxygen-icons</application> en exécutant
     les commandes suivantes :</para>
+    <note><para>Contrairement à la plupart des paquets de cette section, les icones sont placées
+    dans /usr afin que les autres applications puissent les trouver.</para></note>
+
 <screen>
 <userinput>mkdir build &&
 cd    build &&

Modified: trunk/blfs/kde/core/pre-install-config.xml
===================================================================
--- trunk/blfs/kde/core/pre-install-config.xml	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/kde/core/pre-install-config.xml	2015-06-29 20:24:56 UTC (rev 6898)
@@ -10,7 +10,7 @@
     <othername>$LastChangedBy : rthomsen $</othername>
     <date>$Date : 2012-04-15 19:19:58 +0200 (Sun, 15 Apr 2012) $</date>
   </sect1info>
-  <title>configuration de la pré-installation de KDE</title>
+  <title>configuration de la pré-installation de KDE4</title>
   <note><para>Si vous n'avez pas installé <application>Xorg</application> dans
   <filename class="directory">/usr</filename>, certain des modules  
   <application>CMake</application> dans <application>KDE</application>

Modified: trunk/blfs/kde/kde.xml
===================================================================
--- trunk/blfs/kde/kde.xml	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/kde/kde.xml	2015-06-29 20:24:56 UTC (rev 6898)
@@ -6,20 +6,29 @@
 ]>
 <part id="kde" xreflabel="KDE">
   <?dbhtml filename="kde.html" dir="kde"?>
-  <title>KDE</title>
+  <title>Introduction à KDE</title>
+<partintro>
+  <para><application>KDE</application> est un environement de bureau compréhensible avec un
+  nombre important d'applications écrites pour lui et un nombre important d'utilisateurs.
+  Il est basé sur la boite à outils <application>Qt</application> framework.</para>
+
+
        
-<para>There are two versions of <application>KDE</application>. KDE4
-is a mature version that combines libraries and the desktop environment
-into one set of packages and has numerous appplications that can be
-built on that base.  For KDE5, the libraries, now called KDE Frameworks
-5 or KF5, are separate from the desktop environment called KDE Plasma 5.
-Both envionments can be installed, but Plasma is not yet considered 
-stable.</para>
-<para>For more information visit the official KDE project site at
+<para>Il y a deux versions de <application>KDE</application>. KDE4
+est une version mature qui combine les bibliothèques et l'environnement de bureau
+dans un ensemble de paquets et a de nombreuses applications qui peuvent être
+construites sur cette base. POur KDE5, les bibliothèquesn maintenant appelée 
+KDE Frameworks5 ou KF5, sont séparées de l'environnement de bureau appelé KDE Plasma 5.
+Les deux environnements peuvent être installés, mais Plasma n'est pas encore considéré comme stable.
+</para>
+<para>POour plus d'information, visitez le site officiel du projet KDE à
 <ulink url="http://www.kde.org/"/>.</para>
 </partintro>
 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="introduction.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="core/core.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="add/add.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="kf5/kf5.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="kf5-apps/kf5-apps.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="plasma5/plasma5.xml"/>
   
 </part>

Added: trunk/blfs/kde/plasma5/plasma5.xml
===================================================================
(Binary files differ)

Index: trunk/blfs/kde/plasma5/plasma5.xml
===================================================================
--- trunk/blfs/kde/plasma5/plasma5.xml	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/kde/plasma5/plasma5.xml	2015-06-29 20:24:56 UTC (rev 6898)

Property changes on: trunk/blfs/kde/plasma5/plasma5.xml
___________________________________________________________________
Added: svn:mime-type
## -0,0 +1 ##
+application/xml
\ No newline at end of property
Modified: trunk/blfs/multimedia/libdriv/pulseaudio.xml
===================================================================
--- trunk/blfs/multimedia/libdriv/pulseaudio.xml	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/multimedia/libdriv/pulseaudio.xml	2015-06-29 20:24:56 UTC (rev 6898)
@@ -133,12 +133,6 @@
       <parameter>--disable-rpath</parameter>: Ce paramètre empêche l'éditeur de lien d'ajouter des
       chemins d'exécution codé en dur dans les programmes et bibliothèques installés.
     </para>
-    <para>
-      <parameter>--with-module-dir=/usr/lib/pulseaudio/modules</parameter> : 
-    Ce paramètre garantit que les modules de <application>PulseAudio</application>
-    s'installent dans <filename class="directory">/usr/lib/pulse/modules
-    </filename> au lieu de <filename class="directory">
-    /usr/lib/pulse-&pulseaudio-major-version;/modules</filename>.</para>
  
   </sect2>
   <sect2 role="configuration">

Modified: trunk/blfs/networking/netutils/wicd.xml
===================================================================
--- trunk/blfs/networking/netutils/wicd.xml	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/networking/netutils/wicd.xml	2015-06-29 20:24:56 UTC (rev 6898)
@@ -29,7 +29,8 @@
     de l'authentification WPA et la configuration DHCP. Il offre des interfaces
     Curses- et graphiques basées sur GTK pour un contrôle convivial. Une
     excellente interface basée sur KDE est également disponible
-    <ulink url="http://projects.kde.org/projects/extragear/network/wicd-kde">ici</ulink>.</para>
+    <ulink url="http://projects.kde.org/projects/extragear/network/wicd-kde">
+    http://projects.kde.org/projects/extragear/network/wicd-kde</ulink>.</para>
     &lfs77_checked;
     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
     <itemizedlist spacing="compact">

Modified: trunk/blfs/server/databases/db.xml
===================================================================
--- trunk/blfs/server/databases/db.xml	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/server/databases/db.xml	2015-06-29 20:24:56 UTC (rev 6898)
@@ -52,7 +52,7 @@
     <bridgehead renderas="sect4">Facultatives</bridgehead>
     <para role="optional">
       <xref linkend="tcl"/>,
-      <xref linkend="openjdk"/> (les liaisons Java sont actuellement cassées avec JDK8)
+      <xref linkend="openjdk"/> ou <xref linkend="java"/>
  et
       <xref linkend="sharutils"/> (pour la commande <command>uudecode</command> - les liaisons Java sont
       requises)
@@ -103,8 +103,7 @@
     <para>
       <option>--enable-java</option> : Active le support
       <application>Java</application> dans DB et crée la bibliothèque
-      <filename class="libraryfile">libdb_java</filename>. Les liaisons Java sont actuellement
-      cassées avec JDK8.
+      <filename class="libraryfile">libdb_java</filename>. 
     </para>
   </sect2>
   <sect2 role="content">

Deleted: trunk/blfs/traduc/commits/r16160.txt
===================================================================
--- trunk/blfs/traduc/commits/r16160.txt	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/traduc/commits/r16160.txt	2015-06-29 20:24:56 UTC (rev 6898)
@@ -1,9 +0,0 @@
-Révision 16160
-
-fichiers modifiés :
-   networking/netprogs/wpa_supplicant.xml
-
-Log :
-GCC5 Tag
-
-Le robot a traité 100 % du commit anglais

Deleted: trunk/blfs/traduc/commits/r16161.txt
===================================================================
--- trunk/blfs/traduc/commits/r16161.txt	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/traduc/commits/r16161.txt	2015-06-29 20:24:56 UTC (rev 6898)
@@ -1,177 +0,0 @@
-Révision 16161
-
-fichiers modifiés :
-   networking/netutils/wicd.xml
-   multimedia/libdriv/pulseaudio.xml
-   general.ent
-   general/prog/cvs.xml
-   general/graphlib/poppler.xml
-   general/genutils/graphviz.xml
-   general/genutils/hd2u.xml
-   introduction/welcome/changelog.xml
-
-Log :
-Wicd-1.7.3: change "here" by the actual link. If not aproved, please, revert or tell me to do it. Hd2u-1.0.3: change Download URL. Graphviz-2.38.0: change Download URL. PulseAudio-6.0: remove uneeded "Command Explanation". CVS-1.11.23: comment out test suite. Poppler-0.33.0: can be compiled with support for QT4 and QT5 at once.
-
-Le robot a traité 28 % du commit anglais
-Index: general/graphlib/poppler.xml
-===================================================================
---- general/graphlib/poppler.xml	(révision 16160)
-+++ general/graphlib/poppler.xml	(révision 16161)
-@@ -148,28 +148,25 @@
- git clone git://git.freedesktop.org/git/poppler/test testfiles</userinput></screen>
- 
-     <note><para>
--This package can be optionally built with support for either the Qt4 or
--Qt5 libraries, but it only builds with one of those at a time. If you
--have both Qt versions installed, you will need to specify which one to
--use before executing the <command>configure</command> command given
--below. Use this command to link to Qt4: 
-+      This package can be optionally built with support for only one version of
-+      Qt4 or Qt5. If you have only one, no modification is necessary. If both
-+      are installed, and you wish support for only one, before executing the
-+      <command>configure</command> command given below, use this command to
-+      select Qt4: 
-       
-       <screen><userinput>source /usr/bin/setqt4</userinput></screen> 
- 
--or use this to use Qt5:
-+      or this to select Qt5:
- 
-       <screen><userinput>source /usr/bin/setqt5</userinput></screen> 
--If you would like <application>Poppler</application> to link to both Qt
--versions, you will need to build it twice.
-     </para></note>
- 
-     <para>
-@@ -177,7 +174,9 @@
-       commands:
-     </para>
- 
--<screen><userinput>./configure --prefix=/usr         \
-+<screen><userinput>MOCQT4=$QT4DIR/bin/moc            \
-+MOCQT5=$QT5DIR/bin/moc            \
-+./configure --prefix=/usr         \
-             --sysconfdir=/etc     \
-             --disable-static      \
-             --enable-xpdf-headers \
-@@ -226,6 +225,15 @@
-   <sect2 role="commands">
-     <title>Command Explanations</title>
- 
-+    <para>
-+      <envar>MOCQT4=$QT4DIR/bin/moc</envar> and
-+      <envar>MOCQT5=$QT5DIR/bin/moc</envar>:
-+      These environment variables are necessary, for linking with the two Qt
-+      versions, if both are installed.  If only one Qt version is installed or
-+      you wish to link to only one version, you can remove them, although this
-+      is not necessary.
-+    </para>
-     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-       href="../../xincludes/static-libraries.xml"/>
- 
-
-Index: general/prog/cvs.xml
-===================================================================
---- general/prog/cvs.xml	(révision 16160)
-+++ general/prog/cvs.xml	(révision 16161)
-@@ -141,19 +141,26 @@
- 
- <screen><userinput>make -C doc html txt</userinput></screen>
- 
--<para>To test the results, issue: <command>make check</command>. This will
-+<!-- developer: test suite still fails, even if the modifications are made
-+     and a further patch:
-+     https://projects.archlinux.org/svntogit/packages.git/plain/trunk/cvs-1.11.23-sanity.patch?h=packages/cvs
-+     is applied.-->
-+<!--    <para>To test the results, issue: <command>make check</command>. This will
-     take quite a while. If you don't have <command>rsh</command> configured for
-     access to the host you are building on (or you didn't pass the
--<option>--with-rsh=</option> parameter to the <command>configure</command>
-+    <option>-\-with-rsh=</option> parameter to the <command>configure</command>
-     script, some tests may fail. If you passed the
--<option>--with-rsh=ssh</option> parameter to enable <command>ssh</command>
-+    <option>-\-with-rsh=ssh</option> parameter to enable <command>ssh</command>
-     as the default remote shell program, you'll need to issue the following
-     command so that the tests will complete without any failures:</para>
- 
- <screen><userinput>sed -e 's/rsh};/ssh};/' \
-+    the string in following expression is not found anywhere in src/sanity.sh
-     -e 's/g=rw,o=r$/g=r,o=r/' \
-    -i src/sanity.sh</userinput></screen>-->
- 
-+    <para>This package does not come with a working test suite.</para>
-     <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
- 
- <screen role='root'><userinput>make install &&
-
-Index: introduction/welcome/changelog.xml
-===================================================================
---- introduction/welcome/changelog.xml	(révision 16160)
-+++ introduction/welcome/changelog.xml	(révision 16161)
-@@ -45,6 +45,29 @@
- -->
- 
-     <listitem>
-+      <para>June 24th, 2015</para>
-+      <itemizedlist>
-+        <listitem>
-+          <para>[fernando] - Poppler-0.33.0 can be compiled with support for
-+          QT4 and QT5 at once.  Fixes
-+          <ulink url="&blfs-ticket-root;6634">#6634</ulink>.</para>
-+        </listitem>
-+        <listitem>
-+          <para>[fernando] - CVS-1.11.23: comment out test suite.  Fixes
-+          <ulink url="&blfs-ticket-root;6636">#6636</ulink>.</para>
-+        </listitem>
-+        <listitem>
-+          <para>[fernando] - PulseAudio-6.0: remove uneeded
-+          "Command Explanation".</para>
-+        </listitem>
-+        <listitem>
-+          <para>[fernando] - Wicd-1.7.3, Hd2u-1.0.3 and Graphviz-2.38.0:
-+          changes related to URL.</para>
-+        </listitem>
-+      </itemizedlist>
-+    </listitem>
-+    <listitem>
-       <para>June 23rd, 2015</para>
-       <itemizedlist>
-         <listitem>
-
-Index: multimedia/libdriv/pulseaudio.xml
-===================================================================
---- multimedia/libdriv/pulseaudio.xml	(révision 16160)
-+++ multimedia/libdriv/pulseaudio.xml	(révision 16161)
-@@ -174,14 +174,6 @@
-       programs and libraries.
-     </para>
- 
--<para>
--<parameter>--with-module-dir=/usr/lib/pulse/modules</parameter>: This
--parameter ensures that <application>PulseAudio</application> modules are
--installed in <filename class="directory">/usr/lib/pulse/modules
--</filename> instead of <filename class="directory">
--/usr/lib/pulse-&pulseaudio-major-version;/modules</filename>.
--</para>
-   </sect2>
- 
-   <sect2 role="configuration">
-
-Index: networking/netutils/wicd.xml
-===================================================================
---- networking/netutils/wicd.xml	(révision 16160)
-+++ networking/netutils/wicd.xml	(révision 16161)
-@@ -34,8 +34,9 @@
-     connecting to wireless and wired networks. Wicd includes support for WPA
-     authentication and DHCP configuration. It provides Curses- and GTK-based
-     graphical frontends for user-friendly control. An excellent KDE-based
--frontend is also available <ulink
--url="http://projects.kde.org/projects/extragear/network/wicd-kde">here</ulink>.
-+    frontend is also available
-+    <ulink url="http://projects.kde.org/projects/extragear/network/wicd-kde">
-+    http://projects.kde.org/projects/extragear/network/wicd-kde</ulink>.
-     </para>
- 
-     &lfs77_checked;
-

Deleted: trunk/blfs/traduc/commits/r16162.txt
===================================================================
--- trunk/blfs/traduc/commits/r16162.txt	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/traduc/commits/r16162.txt	2015-06-29 20:24:56 UTC (rev 6898)
@@ -1,61 +0,0 @@
-Révision 16162
-
-fichiers modifiés :
-   introduction/welcome/changelog.xml
-   gnome.ent
-   packages.ent
-   gnome/applications/epiphany.xml
-   server/databases/db.xml
-   x/installing/mesalib.xml
-
-Log :
-Update to Berkeley DB 6.1.26. Update to mesa-10.5.8. Update to epiphany-3.16.2.
-
-Le robot a traité 66 % du commit anglais
-Index: introduction/welcome/changelog.xml
-===================================================================
---- introduction/welcome/changelog.xml	(révision 16161)
-+++ introduction/welcome/changelog.xml	(révision 16162)
-@@ -48,6 +48,18 @@
-       <para>June 24th, 2015</para>
-       <itemizedlist>
-         <listitem>
-+          <para>[fernando] - Update to epiphany-3.16.2.  Fixes
-+          <ulink url="&blfs-ticket-root;6644">#6644</ulink>.</para>
-+        </listitem>
-+        <listitem>
-+          <para>[fernando] - Update to mesa-10.5.8.  Fixes
-+          <ulink url="&blfs-ticket-root;6643">#6643</ulink>.</para>
-+        </listitem>
-+        <listitem>
-+          <para>[fernando] - Update to Berkeley DB 6.1.26.  Fixes
-+          <ulink url="&blfs-ticket-root;6642">#6642</ulink>.</para>
-+        </listitem>
-+        <listitem>
-           <para>[fernando] - Poppler-0.33.0 can be compiled with support for
-           QT4 and QT5 at once.  Fixes
-           <ulink url="&blfs-ticket-root;6634">#6634</ulink>.</para>
-
-Index: server/databases/db.xml
-===================================================================
---- server/databases/db.xml	(révision 16161)
-+++ server/databases/db.xml	(révision 16162)
-@@ -76,8 +76,7 @@
-     <bridgehead renderas="sect4">Optional</bridgehead>
-     <para role="optional">
-       <xref linkend="tcl"/>,
--<xref linkend="openjdk"/> (the Java bindings are currently broken with
--JDK8)<!-- or <xref linkend="jdk"/> -->, and
-+      <xref linkend="openjdk"/> or <xref linkend="java"/>, and
-       <xref linkend="sharutils"/> (for the <command>uudecode</command> command
-       - Java bindings are required)
-     </para>
-@@ -246,7 +245,6 @@
-       <option>--enable-java</option>: Enables <application>Java</application>
-       support in DB and creates the
-       <filename class="libraryfile">libdb_java</filename> libraries.
--The Java bindings are currently broken with JDK8.
-     </para>
-   </sect2>
- 
-

Deleted: trunk/blfs/traduc/commits/r16163.txt
===================================================================
--- trunk/blfs/traduc/commits/r16163.txt	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/traduc/commits/r16163.txt	2015-06-29 20:24:56 UTC (rev 6898)
@@ -1,659 +0,0 @@
-Révision 16163
-
-fichiers modifiés :
-   general.ent
-   packages.ent
-   x/lib/qt4.xml
-   x/lib/qt5.xml
-   general/prog/tcl.xml
-   general/prog/valgrind.xml
-
-Log :
-Update qt4 and qt5 instructions Prep for KF5 Temove some tab characters
-
-Le robot a traité 12 % du commit anglais
-Index: general.ent
-===================================================================
---- general.ent	(révision 16162)
-+++ general.ent	(révision 16163)
-@@ -156,3 +156,9 @@
-                           building with multiple processors.  See <xref 
-                           linkend='parallel-builds'/> for more information.</para></note>">
- 
-+<!-- KF5 entities -->
-+<!ENTITY kf5-version       "5.11.0">
-+<!ENTITY kf5-base          "5.11">
-+<!ENTITY kf5-download-http "http://download.kde.org/stable/frameworks/&kf5-base;"> 
-+<!ENTITY kf5-download-ftp  "ftp://ftp.kde.org/pub/kde/stable/frameworks/&kf5-base;">
-
-Index: general/prog/tcl.xml
-===================================================================
---- general/prog/tcl.xml	(révision 16162)
-+++ general/prog/tcl.xml	(révision 16163)
-@@ -180,12 +180,6 @@
-     <title>Command Explanations</title>
- 
-     <para>
--<option>--without-tzdata</option>: This switch prevents installation
--of the shipped timezone data which are older than the ones provided
--in LFS.
--</para>
--<para>
-       <parameter>$([ $(uname -m) = x86_64 ] && echo
-       --enable-64bit)</parameter>: This switch is used to enable 64 bit
-       support in <application>Tcl</application> on 64 bit operating
-
-Index: general/prog/valgrind.xml
-===================================================================
---- general/prog/valgrind.xml	(révision 16162)
-+++ general/prog/valgrind.xml	(révision 16163)
-@@ -118,15 +118,15 @@
- 
-     <para>
-       Install <application>Valgrind</application> by running the following
--commands:
--</para>
--
--<screen><userinput>sed -e 's#|3.\*#&|4.\*#' \
---e 's/-mt//g'        \
---i configure         &&
--sed -i 's|/doc/valgrind||' docs/Makefile.in &&
--
--./configure --prefix=/usr \
-+      commands:
-+    </para>
-+<screen><userinput>sed -e 's#|3.\*#&|4.\*#' \
-+    -e 's/-mt//g'        \
-+    -i configure         &&
-+sed -i 's|/doc/valgrind||' docs/Makefile.in &&
-+./configure --prefix=/usr \
-             --datadir=/usr/share/doc/valgrind-&valgrind-version; &&
- make</userinput></screen>
- 
-
-Index: x/lib/qt4.xml
-===================================================================
---- x/lib/qt4.xml	(révision 16162)
-+++ x/lib/qt4.xml	(révision 16163)
-@@ -4,8 +4,11 @@
-   %general-entities;
- 
-   <!ENTITY qt4-download-http
--"http://download.qt-project.org/official_releases/qt/4.8/&qt4-version;/qt-everywhere-opensource-src-&qt4-version;.tar.gz">
-+           "&qt4-url;;/&qt4-version;/qt-everywhere-opensource-src-&qt4-version;.tar.gz">
-   <!ENTITY qt4-download-ftp  " ">
-   <!ENTITY qt4-md5sum        "d990ee66bf7ab0c785589776f35ba6ad">
-   <!ENTITY qt4-size          "230 MB">
-@@ -28,15 +31,15 @@
-   </indexterm>
- 
-   <sect2 role="package">
--<title>Introduction to Qt</title>
-+    <title>Introduction to Qt4</title>
- 
-     <para>
--<application>Qt</application> is a cross-platform application
--framework that is widely used for developing application software
--with a graphical user interface (GUI) (in which cases Qt is classified
--as a widget toolkit), and also used for developing non-GUI programs such
--as command-line tools and consoles for servers. One of the major users
--of <application>Qt</application> is <application>KDE</application>.
-+      <application>Qt4</application> is a cross-platform application framework
-+      that is widely used for developing application software with a graphical
-+      user interface (GUI) (in which cases Qt4 is classified as a widget
-+      toolkit), and also used for developing non-GUI programs such as
-+      command-line tools and consoles for servers. One of the major users of
-+      <application>Qt</application> is <application>KDE4</application>.
-     </para>
- 
-     &lfs77_checked; &gcc5_checked;
-@@ -114,31 +117,21 @@
-   <sect2 role="qt4-prefix">
-     <title>Setting the installation prefix</title>
- 
--<bridgehead renderas="sect3">Installing in /usr</bridgehead>
-+    <bridgehead renderas="sect3">Installing in /opt/qt4</bridgehead>
- 
-     <para>
--If you want to install <application>Qt4</application>
--in <filename class="directory">/usr</filename>, set the
-+      The BLFS editors recommend installing <application>Qt4</application> in a
-+      directory other than <filename class="directory">/usr</filename>, ie
-+      <filename class="directory">/opt/qt4</filename>.  To do this, set the
-       following environment variable:
-     </para>
- 
--<screen><userinput>export QT4PREFIX=/usr</userinput></screen>
--<bridgehead renderas="sect3">Installing in /opt/qt4</bridgehead>
--<para>
--If you want to install <application>Qt4</application>
--in a directory other than <filename
--class="directory">/usr</filename>, ie
--<filename class="directory">/opt/qt4</filename>, set
--the following environment variable:
--</para>
- <screen><userinput>export QT4PREFIX=/opt/qt4</userinput></screen>
- 
-     <tip>
-@@ -166,16 +159,8 @@
-   </sect2>
- 
-   <sect2 role="installation">
--<title>Installation of Qt</title>
-+    <title>Installation of Qt4</title>
- 
--<caution>
--<para>
--If you did not install some of the recommended dependencies, examine
--<command>./configure --help</command> output to check how to disable
--them or use internal versions bundled in the source tarball.
--</para>
--</caution>
-     <warning>
-       <para>
-         If <application>Qt4</application> is being reinstalled into the
-@@ -187,45 +172,61 @@
-       </para>
-     </warning>
- 
-+    <caution>
-+      <para>
-+        If you did not install some of the recommended dependencies, examine
-+        <command>./configure --help</command> output to check how to disable
-+        them or use internal versions bundled in the source tarball.
-+      </para>
-+    </caution>
-     <note>
-       <para>
-         The build time and space required for the full
--<application>Qt</application> is quite long. The instructions below
--do not build the tutorials and examples. Removing the
-+        <application>Qt3</application> is quite long. The instructions below do
-+        not build the tutorials and examples. Removing the
-         <parameter>-nomake</parameter> lines will create a complete build.
-       </para>
-     </note>
- 
-+    <note>
-+      <para>
-+        The BLFS editors do not recommend installing <application>Qt4</application>
-+        into the /usr hierarchy because it becomes difficult to find
-+        components and to update to a new version.  If you do want to install
-+        <application>Qt4</application> in /usr, the directories need to
-+        be specified explicitly.  In this case, set QT4PREFIX=/usr and add 
-+        the following to the configure arguments below:</para>
-+        <screen><userinput>-bindir         /usr/bin/qt4                \
-+-plugindir      /usr/lib/qt4/plugins        \
-+-importdir      /usr/lib/qt4/imports        \
-+-headerdir      /usr/include/qt4            \
-+-datadir        /usr/share/qt4              \
-+-docdir         /usr/share/doc/qt4          \
-+-translationdir /usr/share/qt4/translations \
-+-demosdir       /usr/share/doc/qt4/demos    \
-+-examplesdir    /usr/share/doc/qt4/examples </userinput></screen>
-+    </note>
-     <para>
--Install <application>Qt4</application> into the <filename
--class='directory'>/usr</filename> hierarchy by running the following
--commands:
-+      Install <application>Qt4</application> by running the following commands:
-     </para>
- 
--<screen><userinput>./configure -prefix         $QT4PREFIX                        \
---sysconfdir     /etc/xdg                          \
---bindir         $QT4BINDIR                        \
---plugindir      $QT4PREFIX/lib/qt4/plugins        \
---importdir      $QT4PREFIX/lib/qt4/imports        \
---headerdir      $QT4PREFIX/include/qt4            \
---datadir        $QT4PREFIX/share/qt4              \
---docdir         $QT4PREFIX/share/doc/qt4          \
---translationdir $QT4PREFIX/share/qt4/translations \
---demosdir       $QT4PREFIX/share/doc/qt4/demos    \
---examplesdir    $QT4PREFIX/share/doc/qt4/examples \
---confirm-license   \
---opensource        \
---release           \
---dbus-linked       \
---openssl-linked    \
---system-sqlite     \
---no-phonon         \
---no-phonon-backend \
---no-openvg         \
---nomake demos      \
---nomake examples   \
---optimized-qmake   &&
-+<screen><userinput>./configure -prefix           $QT4PREFIX \
-+            -sysconfdir       /etc/xdg   \
-+            -confirm-license             \
-+            -opensource                  \
-+            -release                     \
-+            -dbus-linked                 \
-+            -openssl-linked              \
-+            -system-sqlite               \
-+            -no-phonon                   \
-+            -no-phonon-backend           \
-+            -no-openvg                   \
-+            -nomake demos                \
-+            -nomake examples             \
-+            -optimized-qmake             &&
- make</userinput></screen>
- 
-     <para>
-@@ -233,42 +234,45 @@
-     </para>
- 
-     <para>
--Remove references to the build directory from the
-+      Now as the <systemitem class="username">root</systemitem> user:
-+    </para>
-+<screen role="root"><userinput>make install &&
-+rm -rf $QT4PREFIX/tests</userinput></screen>
-+    <para>
-+      Remove references to the build directory from the installed
-       <filename class="extension">.pc</filename> files by running
-       the following command:
-     </para>
- 
--<screen><userinput>find . -name "*.pc" -exec perl -pi -e "s, -L$PWD/?\S+,,g" {} \;</userinput></screen>
-+<screen><userinput>find $QT4PREFIX/lib/pkgconfig -name "*.pc" -exec perl -pi -e "s, -L$PWD/?\S+,,g" {} \;</userinput></screen>
- 
--<para>Now as the <systemitem class="username">root</systemitem> user:</para>
--<screen role="root"><userinput>make install &&
--rm -rf /usr/tests</userinput></screen>
-     <para>
--Remove references to the build directory from installed files by
--running the following command as the
-+      Remove references to the build directory in the installed library dependency
-+      (prl) files by running the following command as the
-       <systemitem class="username">root</systemitem> user:
-     </para>
- 
--<screen role="root"><userinput>for file in 3Support CLucene Core DBus Declarative DesignerComponents \
--Designer Gui Help Multimedia Network OpenGL Script \
--ScriptTools Sql Svg Test UiTools WebKit XmlPatterns Xml phonon; do
-+<screen role="root"><userinput>for file in $QT4PREFIX/lib/libQt*.prl; do
-+     sed -r -e '/^QMAKE_PRL_BUILD_DIR/d'    \
-+            -e 's/(QMAKE_PRL_LIBS =).*/\1/' \
-+            -i $file
-+done</userinput></screen>
- 
--[ -e /usr/lib/libQt${file}.prl ] &&
--sed -r '/^QMAKE_PRL_BUILD_DIR/d;s/(QMAKE_PRL_LIBS =).*/\1/' \
---i /usr/lib/libQt${file}.prl
--done
--unset file</userinput></screen>
-     <para>
--Install images and create the menu entries 
--for installed applications.  Be sure that the <envar>QT4PREFIX</envar>
--variable is defined in root's environment and 
--as the <systemitem class="username">root</systemitem> user:
-+      Install images and create the menu entries for installed applications.
-+      The <envar>QT4BINDIR</envar> variable is used here to point to the
-+      directory for the executable programs.  If you have changed the bindir
-+      above, <envar>QT4BINDIR</envar> will need to be adjusted below.  Be sure
-+      that the <envar>QT4BINDIR</envar> variable is defined in root's
-+      environment and as the <systemitem class="username">root</systemitem>
-+      user:
-     </para>
- 
--<screen role="root"><userinput>install -v -Dm644 src/gui/dialogs/images/qtlogo-64.png \
-+<screen role="root"><userinput>QT4BINDIR=$QT4PREFIX/bin
-+install -v -Dm644 src/gui/dialogs/images/qtlogo-64.png \
-                   /usr/share/pixmaps/qt4logo.png       &&
- 
- install -v -Dm644 tools/assistant/tools/assistant/images/assistant-128.png \
-@@ -289,7 +293,7 @@
- <literal>[Desktop Entry]
- Name=Qt4 Assistant 
- Comment=Shows Qt4 documentation and examples
--Exec=$QT4PREFIX/bin/assistant
-+Exec=$QT4BINDIR/assistant
- Icon=assistant-qt4.png
- Terminal=false
- Encoding=UTF-8
-@@ -301,7 +305,7 @@
- <literal>[Desktop Entry]
- Name=Qt4 Designer
- Comment=Design GUIs for Qt4 applications
--Exec=$QT4PREFIX/bin/designer
-+Exec=$QT4BINDIR/designer
- Icon=designer-qt4.png
- MimeType=application/x-designer;
- Terminal=false
-@@ -314,7 +318,7 @@
- <literal>[Desktop Entry]
- Name=Qt4 Linguist 
- Comment=Add translations to Qt4 applications
--Exec=$QT4PREFIX/bin/linguist
-+Exec=$QT4BINDIR/linguist
- Icon=linguist-qt4.png
- MimeType=text/vnd.trolltech.linguist;application/x-linguist;
- Terminal=false
-@@ -328,7 +332,7 @@
- Name=Qt4 QDbusViewer 
- GenericName=D-Bus Debugger
- Comment=Debug D-Bus applications
--Exec=$QT4PREFIX/bin/qdbusviewer
-+Exec=$QT4BINDIR/qdbusviewer
- Icon=qdbusviewer-qt4.png
- Terminal=false
- Encoding=UTF-8
-@@ -340,7 +344,7 @@
- <literal>[Desktop Entry]
- Name=Qt4 Config 
- Comment=Configure Qt4 behavior, styles, fonts
--Exec=$QT4PREFIX/bin/qtconfig
-+Exec=$QT4BINDIR/qtconfig
- Icon=qt4logo.png
- Terminal=false
- Encoding=UTF-8
-@@ -348,6 +352,14 @@
- Categories=Qt;Settings;</literal>
- EOF</userinput></screen>
- 
-+    <para>Some packages such as <xref linkend='vlc'/> look for certain
-+    executables with a -qt4 suffix.  Run the following command as the root user
-+    to create the necessary symlinks:</para>
-+<screen role="root"><userinput>for file in moc uic rcc qmake lconvert lrelease lupdate; do
-+  ln -sfrvn $QT4BINDIR/$file /usr/bin/$file-qt4
-+done</userinput></screen>
-   </sect2>
- 
-   <sect2 role="commands">
-@@ -435,13 +447,14 @@
- <literal># Begin /etc/profile.d/qt4.sh
- 
- QT4DIR=/usr
--export QT4DIR
-+QTDIR=$QT4DIR
-+export QT4DIR QTDIR
- 
- # End /etc/profile.d/qt4.sh</literal>
- EOF</userinput></screen>
- 
-    <para>
--If you installed <application>Qt</application> in a location other
-+      If you installed <application>Qt4</application> in a location other
-       than /usr, you need to update the following configuration files so
-       that <application>Qt</application> is correctly found by other packages
-       and system processes.</para>
-@@ -474,11 +487,12 @@
- <literal># Begin /etc/profile.d/qt4.sh
-    
- QT4DIR=/opt/qt4
-+QTDIR=$QT4DIR
-    
--pathappend /opt/qt4/bin           PATH
--pathappend /opt/qt4/lib/pkgconfig PKG_CONFIG_PATH
-+pathappend $QT4DIR/bin           PATH
-+pathappend $QT4DIR/lib/pkgconfig PKG_CONFIG_PATH
-    
-export QT4DIR QTDIR
-    
-
-Index: x/lib/qt5.xml
-===================================================================
---- x/lib/qt5.xml	(révision 16162)
-+++ x/lib/qt5.xml	(révision 16163)
-@@ -138,25 +137,15 @@
-   <sect2 role="qt5-prefix">
-     <title>Setting the installation prefix</title>
- 
--<bridgehead renderas="sect3">Installing in /usr</bridgehead>
-+    <bridgehead renderas="sect3">Installing in /opt/qt5</bridgehead>
- 
-     <para>
--If you want to install <application>Qt5</application>
--in <filename class="directory">/usr</filename>, set the
-+      The BLFS editors recommend installing <application>Qt5</application> in a
-+      directory other than <filename class="directory">/usr</filename>, ie
-+      <filename class="directory">/opt/qt5</filename>.  To do this,  set the 
-       following environment variable:
-     </para>
- 
--<screen><userinput>export QT5PREFIX=/usr</userinput></screen>
--<bridgehead renderas="sect3">Installing in /opt/qt5</bridgehead>
--<para>
--If you want to install <application>Qt5</application> in a directory
--other than <filename class="directory">/usr</filename>, ie <filename
--class="directory">/opt/qt4</filename>, set the following environment
--variable:
--</para>
- <screen><userinput>export QT5PREFIX=/opt/qt5</userinput></screen>
- 
-     <tip>
-@@ -174,7 +163,7 @@
- 
-       <para>
-         Later on, you may want to install other versions of
--<application>Qt4</application>. To do that, just remove the symlink
-+        <application>Qt5</application>. To do that, just remove the symlink
-         and use <filename class="directory">/opt/qt5</filename> as the
-         prefix again. Which version of <application>Qt5</application> you
-         use depends only on where the symlink points.
-@@ -186,14 +175,6 @@
-   <sect2 role="installation">
-     <title>Installation of Qt5</title>
- 
--<caution>
--<para>
--If you did not install some of the recommended dependencies, examine
--<command>./configure --help</command> output to check how to disable
--them or use internal versions bundled in the source tarball.
--</para>
--</caution>
-     <warning>
-       <para>
-         If <application>Qt5</application> is being reinstalled into the
-@@ -205,31 +186,60 @@
-       </para>
-     </warning>
- 
-+    <caution>
-+      <para>
-+        If you did not install some of the recommended dependencies, examine
-+        <command>./configure --help</command> output to check how to disable
-+        them or use internal versions bundled in the source tarball.
-+      </para>
-+    </caution>
-+    <note>
-+      <para>
-+        The build time and space required for the full
-+        <application>Qt5</application> is quite long. The instructions below
-+        do not build the tutorials and examples. Removing the
-+        <parameter>-nomake</parameter> line will create a complete build.
-+      </para>
-+    </note>
-+    <note>
-+      <para>
-+        The BLFS editors do not recommend installing <application>Qt5</application>
-+        into the /usr hierarchy because it becomes difficult to find
-+        components and to update to a new version.  If you do want to install
-+        <application>Qt5</application> in /usr, the directories need to
-+        be specified explicitly.  In this case, set QT5PREFIX=/usr and add
-+        the following to the configure arguments below:</para>
-+        <screen><userinput>-bindir         /usr/bin/qt4                \
-+-plugindir      /usr/lib/qt5/plugins        \
-+-importdir      /usr/lib/qt5/imports        \
-+-headerdir      /usr/include/qt5            \
-+-datadir        /usr/share/qt5              \
-+-docdir         /usr/share/doc/qt5          \
-+-translationdir /usr/share/qt5/translations \
-+-demosdir       /usr/share/doc/qt5/demos    \
-+-examplesdir    /usr/share/doc/qt5/examples </userinput></screen>
-+    </note>
-     <para>
-      Install <application>Qt5</application> by running the following commands:
-     </para>
- 
--<screen><userinput>./configure -prefix         $QT5PREFIX                        \
---sysconfdir     /etc/xdg                          \
---bindir         $QT5BINDIR                        \
---headerdir      $QT5PREFIX/include/qt5            \
---archdatadir    $QT5PREFIX/lib/qt5                \
---datadir        $QT5PREFIX/share/qt5              \
---docdir         $QT5PREFIX/share/doc/qt5          \
---translationdir $QT5PREFIX/share/qt5/translations \
---examplesdir    $QT5PREFIX/share/doc/qt5/examples \
---confirm-license  \
---opensource       \
---dbus-linked      \
---openssl-linked   \
---journald         \
---system-harfbuzz  \
---system-sqlite    \
---nomake examples  \
---no-rpath         \
---optimized-qmake  \
---skip qtwebengine &&
-+<screen><userinput>./configure -prefix         $QT5PREFIX \
-+            -sysconfdir     /etc/xdg   \
-+            -confirm-license           \
-+            -opensource                \
-+            -dbus-linked               \
-+            -openssl-linked            \
-+            -journald                  \
-+            -system-harfbuzz           \
-+            -system-sqlite             \
-+            -nomake examples           \
-+            -no-rpath                  \
-+            -optimized-qmake           \
-+            -skip qtwebengine          &&
- 
- make</userinput></screen>
- 
-@@ -238,40 +248,45 @@
-     </para>
- 
-     <para>
--Remove references to the build directory from the
--<filename class="extension">.pc</filename> files by running
--the following command:
-+      Now, as the <systemitem class="username">root</systemitem> user:
-     </para>
- 
--<screen><userinput>find . -name "*.pc" -exec perl -pi -e "s, -L$PWD/?\S+,,g" {} \;</userinput></screen>
-+<screen role="root"><userinput>make install</userinput></screen>
- 
-     <para>
--Now, as the <systemitem class="username">root</systemitem> user:
-+      Remove references to the build directory from the installed
-+      <filename class="extension">.pc</filename> files by running
-+      the following command:
-     </para>
- 
--<screen role="root"><userinput>make install</userinput></screen>
-+<screen><userinput>find $QT5PREFIX/lib/pkgconfig -name "*.pc" -exec perl -pi -e "s, -L$PWD/?\S+,,g" {} \;</userinput></screen>
- 
-     <para>
--Remove references to the build directory from installed files by
--running the following commands as the
--<systemitem class="username">root</systemitem> user:
-+      Remove references to the build directory from installed library dependency
-+      (prl) and profile include (pri) files by running the following commands as 
-+      the <systemitem class="username">root</systemitem> user:
-     </para>
- 
- <screen role="root"><userinput>sed -e "s:$PWD/qtbase:/usr/lib/qt5:g" \
---i /usr/lib/qt5/mkspecs/modules/qt_lib_bootstrap_private.pri &&
-+    -i $QT5PREFIX/lib/qt5/mkspecs/modules/qt_lib_bootstrap_private.pri &&
- 
--find /usr/lib/lib{qgsttools_p,Qt5*}.prl -exec sed -i -r \
-+find $QT5PREFIX/lib/lib{qgsttools_p,Qt5*}.prl -exec sed -i -r \
-      '/^QMAKE_PRL_BUILD_DIR/d;s/(QMAKE_PRL_LIBS =).*/\1/' {} \;</userinput></screen>
- 
-     <para>
--Install images and create the menu entries
--for installed applications.  Be sure that the <envar>QT5PREFIX</envar>
--variable is defined in root's environment and
--as the <systemitem class="username">root</systemitem> user:
-+      Install images and create the menu entries for installed applications.
-+      The <envar>QT4BINDIR</envar> variable is used here to point to the
-+      directory for the executable programs.  If you have changed the bindir
-+      above, <envar>QT4BINDIR</envar> will need to be adjusted below.  Be sure
-+      that the <envar>QT5BINDIR</envar> variable is defined in root's
-+      environment and as the <systemitem class="username">root</systemitem>
-+      user:
-     </para>
- 
--<screen role="root"><userinput>install -v -dm755 /usr/share/pixmaps/                  &&
-+<screen role="root"><userinput>QT5BINDIR=$QT5PREFIX/bin
- 
-+install -v -dm755 /usr/share/pixmaps/                  &&
- install -v -Dm644 qttools/src/assistant/assistant/images/assistant-128.png \
-                   /usr/share/pixmaps/assistant-qt5.png &&
- 
-@@ -290,7 +305,7 @@
- <literal>[Desktop Entry]
- Name=Qt5 Assistant 
- Comment=Shows Qt5 documentation and examples
--Exec=$QT5PREFIX/bin/assistant
-+Exec=$QT5BINDIR/assistant
- Icon=assistant-qt5.png
- Terminal=false
- Encoding=UTF-8
-@@ -303,7 +318,7 @@
- Name=Qt5 Designer
- GenericName=Interface Designer
- Comment=Design GUIs for Qt5 applications
--Exec=$QT5PREFIX/bin/designer
-+Exec=$QT5BINDIR/designer
- Icon=designer-qt5.png
- MimeType=application/x-designer;
- Terminal=false
-@@ -316,7 +331,7 @@
- <literal>[Desktop Entry]
- Name=Qt5 Linguist
- Comment=Add translations to Qt5 applications
--Exec=$QT5PREFIX/bin/linguist
-+Exec=$QT5BINDOR/linguist
- Icon=linguist-qt5.png
- MimeType=text/vnd.trolltech.linguist;application/x-linguist;
- Terminal=false
-@@ -330,7 +345,7 @@
- Name=Qt5 QDbusViewer 
- GenericName=D-Bus Debugger
- Comment=Debug D-Bus applications
--Exec=$QT5PREFIX/bin/qdbusviewer
-+Exec=$QT5BINDIR/qdbusviewer
- Icon=qdbusviewer-qt5.png
- Terminal=false
- Encoding=UTF-8
-@@ -338,6 +353,14 @@
- Categories=Qt;Development;Debugger;</literal>
- EOF</userinput></screen>
- 
-+    <para>Some packages such as <xref linkend='vlc'/> look for certain
-+    executables with a -qt5 suffix.  Run the following command as the root user
-+    to create the necessary symlinks:</para>
-+<screen role="root"><userinput>for file in moc uic rcc qmake lconvert lrelease lupdate; do
-+  ln -sfrvn $QT5BINDIR/$file /usr/bin/$file-qt5
-+done</userinput></screen>
-   </sect2>
- 
-   <sect2 role="commands">
-@@ -366,13 +389,6 @@
-     </para>
- 
-     <para>
--<parameter>-nomake tests</parameter>: This switch
--disables building of the test programs included
--in the source tarball. Remove it if you want to build
--them.
--</para>
--<para>
-       <parameter>-system-sqlite</parameter>: This switch enables use
-       of the system version of <application>SQLite</application>.
-     </para>
-@@ -473,8 +489,8 @@
- 
- QT5DIR=/opt/qt5
- 
--pathappend /opt/qt5/bin           PATH
--pathappend /opt/qt5/lib/pkgconfig PKG_CONFIG_PATH
-+pathappend $QT5DIR/bin           PATH
-+pathappend $QT5DIR/lib/pkgconfig PKG_CONFIG_PATH
- 
- export QT5DIR
- 
-

Deleted: trunk/blfs/traduc/commits/r16164.txt
===================================================================
--- trunk/blfs/traduc/commits/r16164.txt	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/traduc/commits/r16164.txt	2015-06-29 20:24:56 UTC (rev 6898)
@@ -1,422 +0,0 @@
-Révision 16164
-
-fichiers supprimés :
-   kde/intro
-   kde/intro/kde-intro.xml
-   kde/intro/pre-install-config.xml
-   kde/intro/introduction.xml
-
-fichiers déplacés (avec ou sans changements) :
-intro
-kde-intro.xml
-pre-install-config.xml
-introduction.xml
-
-fichiers ajoutés :
-   kde/plasma5/plasma5.xml
-   kde/plasma5
-   kde/kf5/kf5.xml
-   kde/kf5/extra-cmake-modules.xml
-   kde/kf5
-   kde/kf5-apps/kf5-apps.xml
-   kde/kf5-apps
-   archive/kde/intro
-
-fichiers modifiés :
-   kde/kde.xml
-   kde/add/add.xml
-   kde/core/attica.xml
-   kde/core/config.xml
-   kde/core/phonon-backend-gstreamer.xml
-   kde/core/oxygen-icons.xml
-   kde/core/polkit-qt.xml
-   kde/core/core.xml
-   kde/core/phonon.xml
-
-Log :
-Reorganize KDE4 and put in placeholders for KF5 and Phonon 5. Oxygen Icons are now put in /usr.
-
-Le robot a traité 64 % du commit anglais
-
-ATTENTION : il faut relire les fichiers suivants qui sont ajoutés
-Index: archive/kde/intro/introduction.xml
-===================================================================
---- kde/intro/introduction.xml	2015-06-29 07:45:57.938630458 +0200
-+++ archive at kde/intro/introduction.xml	2015-06-29 07:45:57.958629672 +0200
-@@ -8,6 +8,7 @@
- <!--
- $LastChangedBy$
- $Date$
-+-->
- 
- <chapter id="kde-prereq">
-   <?dbhtml filename="introduction.html"?>
-@@ -15,6 +16,16 @@
-   <title>Introduction</title>
- 
-   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="kde-intro.xml"/>
--<xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="pre-install-config.xml"/>
-+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="extra-cmake-modules.xml"/>
-+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="phonon.xml"/>
-+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="phonon-backend-gstreamer.xml"/>
-+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="phonon-backend-vlc.xml"/>
-+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="polkit-qt.xml"/>
- 
- </chapter>
-+Modification de propriétés sur archive/kde/intro/introduction.xml
-+___________________________________________________________________
-+Added: svn:keywords
-+## -0,0 +1 ##
-+LastChangedBy Date
-+\ No newline at end of property
-
-Index: archive/kde/intro/kde-intro.xml
-===================================================================
---- kde at intro@kde-intro.xml.16164.temp	2015-06-29 07:45:56.798675223 +0200
-+++ archive at kde@intro at kde-intro.xml.16164.temp	2015-06-29 07:45:56.808674830 +0200
-@@ -15,19 +15,36 @@
- 
-   <title>Introduction to KDE</title>
- 
--<para><application>KDE</application> Software Compilation 4 is a
--comprehensive desktop environment with a huge number of applications
--written for it and a huge amount of users. It is based on the
--<application>Qt</application> framework.</para>
-+  <para><application>KDE</application> is a comprehensive desktop environment
-+  with a huge number of applications written for it and a huge amount of users.
-+  It is based on the <application>Qt</application> framework.</para>
-+  <para>There are two versions of <application>KDE</application>. KDE4
-+  is a mature version that combines libraries and the desktop environment
-+  into one set of packages and has numerous appplications that can be
-+  built on that base.  For KDE5, the libraries, now called KDE Frameworks
-+  5 or KF5, are separate from the desktop environment called KDE Plasma 5.
-+  Both envionments can be installed, but Plasma is not yet considered 
-+  stable.</para>
-   <para>For more information visit the official KDE project site at
-   <ulink url="http://www.kde.org/"/>.</para>
- 
--<sect2><title>Build order</title>
-+  <sect2><title>Common Packages</title>
-+  <para>There are several packages that are common to both versions of KDE.
-+  These packages are presented in the following sections of this chapter.</para>
- 
--<para>The core <application>KDE</application> packages are listed in the
-+  <!-- <para>The core <application>KDE</application> packages are listed in the
-   recommended and tested build order. The additional
-  <application>KDE</application> packages can be built in any order.</para>-->
- 
-   </sect2>
- 
- </sect1>
-+Modification de propriétés sur archive/kde/intro/kde-intro.xml
-+___________________________________________________________________
-+Added: svn:keywords
-+## -0,0 +1 ##
-+LastChangedBy Date
-+\ No newline at end of property
-
-Index: kde/add/add.xml
-===================================================================
---- kde/add/add.xml	(révision 16163)
-+++ kde/add/add.xml	(révision 16164)
-@@ -13,7 +13,7 @@
- <chapter id="kde-add">
-   <?dbhtml filename="add.html"?>
- 
--<title>KDE Additional Packages</title>
-+  <title>KDE4 Additional Packages</title>
-   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="konsole.xml"/>
-   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="kate.xml"/>
-   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="ark.xml"/>
-
-Index: kde/core/attica.xml
-===================================================================
---- kde/core/attica.xml	(révision 16163)
-+++ kde/core/attica.xml	(révision 16164)
-@@ -64,13 +64,6 @@
-       <xref linkend="qt4"/>
-     </para>
- 
--<bridgehead renderas="sect4">Optional</bridgehead>
--<para role="optional">
--<xref linkend="qt5"/> (requires
--<ulink url="http://quickgit.kde.org/index.php?p=extra-cmake-modules.git">
--extra-cmake-modules</ulink>)
--</para>
-     <para condition="html" role="usernotes">User Notes:
-     <ulink url="&blfs-wiki;/attica"/></para>
- 
-
-Index: kde/core/config.xml
-===================================================================
---- kde/core/config.xml	(révision 16163)
-+++ kde/core/config.xml	(révision 16164)
-@@ -5,7 +5,7 @@
-   %general-entities;
- ]>
- 
--<sect1 id="kde-core-config" xreflabel="Starting KDE">
-+<sect1 id="kde-core-config" xreflabel="Starting KDE4">
-   <?dbhtml filename="config.html"?>
- 
-   <sect1info>
-@@ -13,9 +13,9 @@
-     <date>$Date$</date>
-   </sect1info>
- 
--<title>Starting KDE</title>
-+  <title>Starting KDE4</title>
- 
--<bridgehead renderas="sect3">KDE Startup Dependencies</bridgehead>
-+  <bridgehead renderas="sect3">KDE4 Startup Dependencies</bridgehead>
- 
-   <bridgehead renderas="sect4">Optional</bridgehead>
-   <para role="optional">
-@@ -24,12 +24,12 @@
- 
-   <para>After <application>Kde-workspace</application> has been installed, the
-   first important milestone has been reached. Now you need to configure your
--system to start KDE.</para>
-+  system to start KDE4.</para>
- 
-   <sect2 role="content">
--<title>Starting KDE from the command prompt</title>
-+  <title>Starting KDE4 from the command prompt</title>
- 
--<para>To start <application>KDE</application> from the command prompt, you
-+ <para>To start <application>KDE4</application> from the command prompt, you
-  first need to modify your <filename>.xinitrc</filename> file:</para>
- 
- <screen><userinput>cat > ~/.xinitrc << EOF
-@@ -43,14 +43,14 @@
-     <note><para>If you are not using <application>ConsoleKit</application>, remove
-     <userinput>ck-launch-session</userinput>.</para></note>
- 
--<para>You can now start KDE using the <command>startx</command> command.</para>
-+    <para>You can now start KDE4 using the <command>startx</command> command.</para>
- 
-     </sect2>
- 
-     <sect2 role="content">
--<title>Starting KDE at boot</title>
-+    <title>Starting KDE4 at boot</title>
- 
--<para>KDE comes with a graphical login interface called KDM (the KDE Display
-+    <para>KDE4 comes with a graphical login interface called KDM (the KDE4 Display
-     Manager), which provides a customizable graphical login at boot. To use KDM,
-     you need to edit your <filename>/etc/inittab</filename> file (as the
-     <systemitem class="username">root</systemitem> user).
-@@ -65,7 +65,7 @@
- 
- <screen><userinput>sed -i 's#id:3:initdefault:#id:5:initdefault:#' /etc/inittab</userinput></screen>
- 
--<para>You can now restart your system and see the KDE login
-+    <para>You can now restart your system and see the KDE4 login
-     screen.</para>
- 
-   </sect2>
-@@ -78,16 +78,16 @@
-     url="&kde-download-http;applications/&kde-apps-version;/src/kde-l10n/">
-          &kde-download-http;applications/&kde-apps-version;/src/kde-l10n/</ulink>.
-     See <xref linkend="kde-add-pkgs"/> for build instructions. If you are in a
--KDE session when installing a new language and configure KDE to use it, the
-+    KDE4 session when installing a new language and configure KDE4 to use it, the
-     session needs to be restarted, in order to see the effects.</para>
- 
-   </sect2>
- 
-   <sect2 role="content">
--<title>Installing further KDE packages</title>
-+    <title>Installing further KDE4 packages</title>
- 
-     <para>Every subsequent package can be built while having
--<application>KDE</application> up and running, but remember to keep
-+    <application>KDE4</application> up and running, but remember to keep
-     <envar>&kde-dir;</envar> and <envar>&qt4-dir;</envar> set.</para>
- 
-   </sect2>
-
-Index: kde/core/core.xml
-===================================================================
---- kde/core/core.xml	(révision 16163)
-+++ kde/core/core.xml	(révision 16164)
-@@ -13,8 +13,9 @@
- <chapter id="kde4-core">
-   <?dbhtml filename="core.html"?>
- 
--<title>The KDE Core</title>
-+  <title>The KDE4 Core</title>
- 
-+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="pre-install-config.xml"/>
-   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="automoc4.xml"/>
-   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="phonon.xml"/>
-   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="phonon-backend-gstreamer.xml"/>
-
-Index: kde/core/oxygen-icons.xml
-===================================================================
---- kde/core/oxygen-icons.xml	(révision 16163)
-+++ kde/core/oxygen-icons.xml	(révision 16164)
-@@ -74,10 +74,13 @@
-     <para>Install <application>Oxygen-icons</application> by running
-     the following commands:</para>
- 
-+    <note><para>Unlike most packages in this section, the icons are placed
-+    in /usr so other applications can find them.</para></note>
- <screen><userinput>mkdir build &&
- cd    build &&
- 
--cmake -DCMAKE_INSTALL_PREFIX=&kde-dir; -Wno-dev ..</userinput></screen>
-+cmake -DCMAKE_INSTALL_PREFIX=/usr -Wno-dev ..</userinput></screen>
- 
-     <para>
-       This package does not come with a test suite.
-
-Index: kde/core/phonon-backend-gstreamer.xml
-===================================================================
---- kde/core/phonon-backend-gstreamer.xml	(révision 16163)
-+++ kde/core/phonon-backend-gstreamer.xml	(révision 16164)
-@@ -69,15 +69,10 @@
-     <xref linkend="gst10-plugins-ugly"/> (needed for MP3 support)
-     </para>
- 
--<bridgehead renderas="sect4">Optional</bridgehead>
--<para role="optional">
--<xref linkend="qt5"/>
--</para>
-     <para condition="html" role="usernotes">User Notes:
-     <ulink url="&blfs-wiki;/phonon-backend-gstreamer"/></para>
- 
-@@ -86,9 +81,16 @@
-    <para>Install <application>Phonon-backend-gstreamer</application> by
-    running the following commands:</para>
- 
-+    <note>
-+      <para>
-+        If you have both Qt4 and Qt5 installed, be sure to run
-+        <userinput>source setqt4</userinput> before installing this package.
-+      </para>
-+    </note> 
- <screen><userinput>mkdir build &&
- cd    build &&
- 
-@@ -123,8 +125,8 @@
-       <seglistitem>
-         <seg>none</seg>
-         <seg>phonon_gstreamer.so</seg>
--<seg>&kde-dir;/lib/kde4/plugins/phonon_backend and 
--&kde-dir;/share/kde4/services/phononbackends</seg>
-+        <seg>/usr/lib/kde4/plugins/phonon_backend and 
-+             /usr/share/kde4/services/phononbackends</seg>
-       </seglistitem>
-     </segmentedlist>
- <!--
-
-Index: kde/core/phonon.xml
-===================================================================
---- kde/core/phonon.xml	(révision 16163)
-+++ kde/core/phonon.xml	(révision 16164)
-@@ -30,8 +30,8 @@
-     <title>Introduction to Phonon</title>
- 
-     <para><application>Phonon</application> is the multimedia API for KDE4.
--It replaces the old <application>aRts</application>, that is no longer
--supported by KDE. Phonon needs either the GStreamer or VLC backend.</para>
-+    It replaces the old <application>aRts</application> package.
-+    Phonon needs either the GStreamer or VLC backend.</para>
- 
-     &lfs77_checked; &gcc5_checked;
- 
-@@ -61,16 +61,14 @@
- 
-     <bridgehead renderas="sect4">Optional</bridgehead>
-     <para role="optional">
--<xref linkend="pulseaudio"/>,
--<xref linkend="qt5"/> and
-+      <xref linkend="pulseaudio"/> and
-       <ulink url="http://projects.kde.org/projects/kdesupport/libqzeitgeist/">QZeitgeist</ulink>
-     </para>
- 
-@@ -82,19 +80,24 @@
-   <sect2 role="installation">
-     <title>Installation of Phonon</title>
- 
--<para>Make sure that <xref linkend="qt4"/> is compiled without the bundled
-+    <para>Make sure <xref linkend="qt4"/> has been built without the bundled
-     <application>Phonon</application> library. This package provides
-     a better implementation.</para>
- 
-@@     @@
-     <para>Install <application>Phonon</application> by running the following
-     commands:</para>
- 
--<!-- CMAKE_INSTALL_LIBDIR is used so the package doesn't write over lib64 symlink on 64 bit system -->
--<screen><userinput>mkdir build &&
-+<screen><userinput>sed -i "s:BSD_SOURCE:DEFAULT_SOURCE:g" cmake/FindPhononInternal.cmake &&
-+mkdir build &&
- cd    build &&
- 
- cmake -DCMAKE_INSTALL_PREFIX=&kde-dir;                         \
-@@ -115,6 +118,11 @@
-     <title>Command Explanations</title>
- 
-     <para>
-+      <command>sed ... cmake/FindPhononInternal.cmake</command>: Silence
-+      a lot of warnings caused by the latest toolchain.
-+    </para>
-+    <para>
-       <parameter>-DCMAKE_BUILD_TYPE=Release</parameter>: This switch is used
-       to apply higher level of the compiler optimizations.
-     </para>
-
-Index: kde/core/pre-install-config.xml
-===================================================================
---- kde at intro@pre-install-config.xml.16164.temp	2015-06-29 07:45:57.298655589 +0200
-+++ kde at core@pre-install-config.xml.16164.temp	2015-06-29 07:45:57.318654804 +0200
-@@ -13,7 +13,7 @@
-     <date>$Date$</date>
-   </sect1info>
- 
--<title>KDE Pre-installation Configuration</title>
-+  <title>KDE4 Pre-installation Configuration</title>
- 
-   <note><para>If you did not install <application>Xorg</application> in
-   <filename class="directory">/usr</filename>, some of the 
-@@ -111,3 +111,9 @@
- 
-   </sect2>
- </sect1>
-+Modification de propriétés sur kde/core/pre-install-config.xml
-+___________________________________________________________________
-+Added: svn:keywords
-+## -0,0 +1 ##
-+LastChangedBy Date
-+\ No newline at end of property
-
-Index: kde/kde.xml
-===================================================================
---- kde/kde.xml	(révision 16163)
-+++ kde/kde.xml	(révision 16164)
-@@ -13,11 +13,29 @@
- <part id="kde" xreflabel="KDE">
-   <?dbhtml filename="kde.html" dir="kde"?>
- 
--<title>KDE</title>
-+  <title>Introduction to KDE</title>
-+<partintro>
-+  <para><application>KDE</application> is a comprehensive desktop environment
-+  with a huge number of applications written for it and a huge amount of users.
-+  It is based on the <application>Qt</application> framework.</para>
- 
-  <para>There are two versions of <application>KDE</application>. KDE4
-  is a mature version that combines libraries and the desktop environment
-@@     @@
-<!--  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="intro/introduction.xml"/>-->
-   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="core/core.xml"/>
-   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="add/add.xml"/>
-+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="kf5/kf5.xml"/>
-+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="kf5-apps/kf5-apps.xml"/>
-+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="plasma5/plasma5.xml"/>
- <!--
-   Language packs!
- -->
-

Modified: trunk/blfs/x/lib/qt4.xml
===================================================================
--- trunk/blfs/x/lib/qt4.xml	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/x/lib/qt4.xml	2015-06-29 20:24:56 UTC (rev 6898)
@@ -24,12 +24,12 @@
   </indexterm>
   <sect2 role="package">
     <title>Introduction à Qt</title>
-    <para><application>Qt</application> est un environnement de travail d'applications
+    <para><application>Qt4</application> est un environnement de travail d'applications
     multi-plate-forme qui est largement utilisé pour développer des applications
-    avec une interface utilisateur graphique (GUI) (dans quelques cas Qt est classé
+    avec une interface utilisateur graphique (GUI) (dans quelques cas Qt4 est classé
     comme une trousse de widgets), et aussi utilisé pour développer des programmes
     non-GUI comme les outils en ligne de commande et les consoles pour les serveurs.
-    Un des utilisateurs majeurs de <application>Qt</application> est <application>KDE</application>.</para>
+    Un des utilisateurs majeurs de <application>Qt</application> est <application>KDE4</application>.</para>
     &lfs77_checked; &gcc5_checked;
     <bridgehead renderas="sect3">Information sur le paquet </bridgehead>
     <itemizedlist spacing="compact">
@@ -103,19 +103,11 @@
 
   <sect2 role="qt4-prefix">
     <title>Initialisation du préfixe d'installation</title>
-    <bridgehead renderas="sect3">Installation dans /usr</bridgehead>
-    <para>
-      Si vous voulez installer <application>Qt4</application>
-      dans <filename class="directory">/usr</filename>, initialisez la variable
-      d'environnement suivante:
-    </para>
-<screen><userinput>export QT4PREFIX=/usr</userinput></screen>
     <bridgehead renderas="sect3">Installation dans /opt/qt4</bridgehead>
     <para>
-      Si vous voulez installer <application>Qt4</application>
-      dans un répertoire autre que <filename
-      class="directory">/usr</filename>, par exemple
-      <filename class="directory">/opt/qt4</filename>, initialisez la varaiable
+      Les éditeurs de BLFS recommandent d'installer <application>Qt4</application>
+      dans un répertoire autre que <filename class="directory">/usr</filename>, par exemple
+       <filename class="directory">/opt/qt4</filename>. Pour cela initialisez la variable
       d'environnement suivante:
     </para>
 <screen><userinput>export QT4PREFIX=/opt/qt4</userinput></screen>
@@ -141,15 +133,7 @@
 
 
    <sect2 role="installation">
-    <title>Installation de Qt</title>
- <caution>
-      <para>
-        Si vous n'installez pas quelques unes des dépendances recommandées,
-	examinez la sortie de <command>./configure --help</command> pour vérifier
-	comment les désactiver ou utiliser les versions internes livrées avec l'archive
-	des sources.
-      </para>
-    </caution>
+    <title>Installation de Qt4</title>
       <warning>
       <para>
        Si <application>Qt4</application> doit être réinstallé dans le même répertoire
@@ -161,6 +145,14 @@
       <application>Qt4</application> qui ne devraient pas être utilisées pendant
       le processus d'installation.</para>
     </warning>
+ <caution>
+      <para>
+        Si vous n'installez pas quelques unes des dépendances recommandées,
+	examinez la sortie de <command>./configure --help</command> pour vérifier
+	comment les désactiver ou utiliser les versions internes livrées avec l'archive
+	des sources.
+      </para>
+    </caution>
     <note>
       <para>Le temps et l'espace de construction requis pour tout
       <application>Qt4</application> est considérable. Les instructions
@@ -168,8 +160,27 @@
       suppression des lignes <parameter>-nomake</parameter> créera une
       construction complète.</para>
     </note>
-      Installez <application>Qt4</application> dans la hiérarchie <filename
-      class='directory'>/usr</filename> en lançant les commandes suivantes
+    <note>
+      <para>
+        Les éditeurs de BLFS ne reocmmandent pas d'installer <application>Qt4</application>
+        dans la hiérarchie /usr car il devient difficile de trouver des composants et de mettre à jour
+        vers une nouvelle version. Si vous voulez installer 
+        <application>Qt4</application> dans /usr, les répertoires ont besoin d'être spécifiés explicitement.
+        Dans ce cas, initialisez QT4PREFIX=/usr et ajoutez
+        la suite aux arguments de configuration:</para>
+        <screen><userinput>-bindir         /usr/bin/qt4                \
+-plugindir      /usr/lib/qt4/plugins        \
+-importdir      /usr/lib/qt4/imports        \
+-headerdir      /usr/include/qt4            \
+-datadir        /usr/share/qt4              \
+-docdir         /usr/share/doc/qt4          \
+-translationdir /usr/share/qt4/translations \
+-demosdir       /usr/share/doc/qt4/demos    \
+-examplesdir    /usr/share/doc/qt4/examples </userinput></screen>
+    </note>
+<para>
+
+      Installez <application>Qt4</application> en lançant les commandes suivantes
     </para>
     
 <screen>
@@ -182,6 +193,12 @@
     <para>
       Ce paquet n'a pas de suite de tests.
     </para>
+     <para>
+      Maintenant en tant qu'utilisateur <systemitem class="username">root</systemitem>:
+    </para>
+<screen role="root"><userinput>make install &&
+rm -rf $QT4PREFIX/tests</userinput></screen>
+
     <para>
       Enlevez les références au répertoire de construction dans les fichiers
       <filename class="extension">.pc</filename> en lançant la commande suivante:
@@ -190,14 +207,8 @@
 <userinput>find . -name "*.pc" -exec perl -pi -e "s, -L$PWD/?S+,,g" {} ;</userinput>
 </screen>
     <para>
-        Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :
-    </para>
-<screen role="root">
-<userinput>make install &&
-rm -rf /usr/tests</userinput>
-</screen>
-    <para>
-      Effacez les références au répertoire d'installation des fichiers installés
+      Effacez les références au répertoire d'installation dans les fichiers de dépendances
+      de bibliothèques installées (prl) 
       en lançant les commandes suivantes en tant qu'utilisateur
       <systemitem class="username">root</systemitem>:
     </para>
@@ -211,8 +222,10 @@
  
       <para>
         Installez les images et créez les entrées
-	de menu pour les applications installées. Soyez certain que la variable
-	<envar>QT4PREFIX</envar> est définie dans l'environnement root et en tant
+	de menu pour les applications installées. La variable <envar>QT4BINDIR</envar> est utilisée ici
+        pour pointer le répertoire des programmes exécutables. Si vous avez modifiez le bindir,
+        <envar>QT4BINDIR</envar> devra être modifié. Soyez certain que la variable
+	<envar>QT4BINDIR</envar> est définie dans l'environnement root et en tant
 	qu'utilisateur <systemitem class="username">root</systemitem> :
       </para>
 <screen role="root">
@@ -281,6 +294,13 @@
 Categories=Qt;Settings;</literal>
 EOF</userinput>
 </screen>
+    <para>Certains paquets comme <xref linkend='vlc'/> cherche certains exécutables avec le suffix -qt4.
+    Lancez la commande suivant en tant qu'utilisateur root pour créer les liens symboliques nécessaires:
+    </para>
+<screen role="root"><userinput>for file in moc uic rcc qmake lconvert lrelease lupdate; do
+  ln -sfrvn $QT4BINDIR/$file /usr/bin/$file-qt4
+done</userinput></screen>
+
 </sect2>
  <sect2 role="commands">
     <title>Explications des commandes</title>
@@ -356,7 +376,7 @@
 EOF</userinput>
 </screen>
    <para>
-      Si vous avez installé <application>Qt</application> dans un endroit autre
+      Si vous avez installé <application>Qt4</application> dans un endroit autre
       que /usr, vous devez mettre à jour les fichiers de configuration
       suivant pour que <application>Qt</application> soit correctement
       trouvé par les autres paquets et les processus du système.</para>
@@ -371,7 +391,7 @@
 <literal># Begin Qt addition
    
 /opt/qt4/lib
-   
+  
 # End Qt addition</literal>
 EOF
 ldconfig</userinput>

Modified: trunk/blfs/x/lib/qt5.xml
===================================================================
--- trunk/blfs/x/lib/qt5.xml	2015-06-29 20:24:31 UTC (rev 6897)
+++ trunk/blfs/x/lib/qt5.xml	2015-06-29 20:24:56 UTC (rev 6898)
@@ -122,19 +122,11 @@
 
   <sect2 role="qt5-prefix">
     <title>Initialisation du préfixe d'installation</title>
-    <bridgehead renderas="sect3">Installation dans /usr</bridgehead>
-    <para>
-      Si vous voulez installer <application>Qt5</application>
-      dans <filename class="directory">/usr</filename>, initialisez la variable
-      d'environnement suivante:
-    </para>
-<screen><userinput>export QT5PREFIX=/usr</userinput></screen>
     <bridgehead renderas="sect3">Installation dans /opt/qt5</bridgehead>
     <para>
-      Si vous voulez installer <application>Qt5</application>
-      dans un répertoire autre que <filename
-      class="directory">/usr</filename>, par exemple
-      <filename class="directory">/opt/qt5</filename>, initialisez la varaiable
+      Les éditeurs de BLFS recommandent d'installer <application>Qt5</application>
+      dans un répertoire autre que <filename class="directory">/usr</filename>, par exemple
+       <filename class="directory">/opt/qt5</filename>. Pour cela initialisez la variable
       d'environnement suivante:
     </para>
 <screen><userinput>export QT5PREFIX=/opt/qt5</userinput></screen>
@@ -162,14 +154,6 @@
 
  <sect2 role="installation">
     <title>Installation de Qt5</title>
-    <caution>
-      <para>
-        Si vous n'installez pas certaine des dépendances recommandées, examinez
-        la sortie de <command>./configure --help</command> pour vérifier comment
-	les désactiver ou utiliser les versions internes livrées avec le paquet
-	des sources.
-      </para>
-     </caution>
       <warning>
      <para>
        Si <application>Qt5</application> doit être réinstallé dans le même répertoire
@@ -181,6 +165,41 @@
       <application>Qt5</application> qui ne devraient pas être utilisées pendant
       le processus d'installation.</para>
       </warning>
+    <caution>
+      <para>
+        Si vous n'installez pas certaine des dépendances recommandées, examinez
+        la sortie de <command>./configure --help</command> pour vérifier comment
+	les désactiver ou utiliser les versions internes livrées avec le paquet
+	des sources.
+      </para>
+     </caution>
+    <note>
+      <para>Le temps et l'espace de construction requis pour tout
+      <application>Qt5</application> est considérable. Les instructions
+      ci-dessous ne construisent pas les tutoriels et les exemples. La
+      suppression des lignes <parameter>-nomake</parameter> créera une
+      construction complète.</para>
+    </note>
+    <note>
+      <para>
+        Les éditeurs de BLFS ne reocmmandent pas d'installer <application>Qt5</application>
+        dans la hiérarchie /usr car il devient difficile de trouver des composants et de mettre à jour
+        vers une nouvelle version. Si vous voulez installer
+        <application>Qt5</application> dans /usr, les répertoires ont besoin d'être spécifiés explicitement.
+        Dans ce cas, initialisez QT5PREFIX=/usr et ajoutez
+        la suite aux arguments de configuration:</para>
+        <screen><userinput>-bindir         /usr/bin/qt5                \
+-plugindir      /usr/lib/qt5/plugins        \
+-importdir      /usr/lib/qt5/imports        \
+-headerdir      /usr/include/qt5            \
+-datadir        /usr/share/qt5              \
+-docdir         /usr/share/doc/qt5          \
+-translationdir /usr/share/qt5/translations \
+-demosdir       /usr/share/doc/qt5/demos    \
+-examplesdir    /usr/share/doc/qt5/examples </userinput></screen>
+    </note>
+<para>
+
    <para>
       Installez <application>Qt5</application> en lançant les commandes suivantes
     </para>
@@ -193,21 +212,22 @@
       Ce paquet n'a pas de suite de tests.
     </para>
     <para>
-      Enlevez les références au répertoire de construction des fichiers  <filename class="extension">.pc</filename>
-      en lançant la commande suivante:
+            Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :
     </para>
 <screen>
 <userinput>find . -name "*.pc" -exec perl -pi -e "s, -L$PWD/?S+,,g" {} ;</userinput>
 </screen>
     <para>
-      Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :
+Enlevez les références au répertoire de construction des fichiers  <filename class="extension">.pc</filename>
+      en lançant la commande suivante:
     </para>
 <screen role="root">
 <userinput>make install</userinput>
 </screen>
     <para>
-      Enlevez les références au répertoire de construction des fichiers installés
-      en lançant la commande suivante en tant qu'utilisateur
+      Effacez les références au répertoire d'installation dans les fichiers de dépendances
+      de bibliothèques installées (prl)
+      en lançant les commandes suivantes en tant qu'utilisateur
       <systemitem class="username">root</systemitem>:
     </para>
 <screen role="root">
@@ -215,10 +235,12 @@
 find /usr/lib/lib{qgsttools_p,Qt5*}.prl -exec sed -i -r      '/^QMAKE_PRL_BUILD_DIR/d;s/(QMAKE_PRL_LIBS =).*/1/' {} ;</userinput>
 </screen>
     <para>
-      Installez les images et créez les entrées de menu pour les
-      applications installées. Soyez certain que la variable <envar>QT5PREFIX</envar>
-      est définie dans l'environnement root et en tant qu'utilisateur
-      <systemitem class="username">root</systemitem> :
+        Installez les images et créez les entrées
+        de menu pour les applications installées. La variable <envar>QT5BINDIR</envar> est utilisée ici
+        pour pointer le répertoire des programmes exécutables. Si vous avez modifiez le bindir,
+        <envar>QT5BINDIR</envar> devra être modifié. Soyez certain que la variable
+        <envar>QT5BINDIR</envar> est définie dans l'environnement root et en tant
+        qu'utilisateur <systemitem class="username">root</systemitem> :
     </para>
 <screen role="root">
 <userinput>install -v -dm755 /usr/share/pixmaps/                  &&
@@ -276,6 +298,14 @@
 Categories=Qt;Development;Debugger;</literal>
 EOF</userinput>
 </screen>
+    <para>Certains paquets comme <xref linkend='vlc'/> cherche certains exécutables avec le suffix -qt4.
+    Lancez la commande suivant en tant qu'utilisateur root pour créer les liens symboliques nécessaires:
+    </para>
+<screen role="root"><userinput>for file in moc uic rcc qmake lconvert lrelease lupdate; do
+  ln -sfrvn $QT4BINDIR/$file /usr/bin/$file-qt4
+done</userinput></screen>
+
+
   </sect2>
   <sect2 role="commands">
     <title>Explications des commandes</title>
@@ -294,11 +324,6 @@
       Ce paramètre désactive la construction des programmes d'exemple inclus dans
       les sources. Enlevez le si vous voulez les construire.
     </para>
-     <para>
-      <parameter>-nomake tests</parameter>: Ce paramètre
-      désactive la construction des programmes de test inclus dans les sources.
-      Enlevez le si vous voulez les construire.
-    </para>
 
     <para>
            <parameter>-system-sqlite</parameter> : Ce paramètre active l'utilisation



Plus d'informations sur la liste de diffusion lfs-traducfr