[links-list] Re: BUG in forms

Anders Widman andewid at tnonline.net
Wed May 1 03:18:56 PDT 2002


> Dear diary, on Wed, May 01, 2002 at 01:47:41AM CEST, I got a letter,
> where Anders Widman <andewid at tnonline.net> told me, that...
>> Links seemd to remove the last part of the originating URL when it
>> looks like this http://www.somehost.com/cgi-program.php?threadid=134
>> 
>> Links will remove everything after cgi-program.php and insert the code
>> from the form.
>> 
>> POSTS that should look like this:
>> 
>> http://www.somehost.com/cgi-program.php?threadid=134&username=moo&password=hello
>> 
>> end up like this:
>> 
>> http://www.somehost.com/cgi-program.php?username=moo&password=hello
>> 
>> which is an obvious bug to me. This does work with Opera, Netscape,
>> WebTV and IE (didn't try with many more).

> This is fixed in Links-0.97pre and ELinks.

I does not seem like that. I have tried with versions up to
0.97-pre12, and the problem is still there. I can easilly reproduce
this problem.

//Anders

> -- 
>                                 Petr "Pasky" Baudis
 
> * ELinks maintainer                * IPv6 guy (XS26 co-coordinator)
> * IRCnet operator                  * FreeCiv AI hacker
> .
> Object orientation is in the mind, not in the compiler. -- Alan Cox
> .
> Public PGP key && geekcode && homepage: http://pasky.ji.cz/~pasky/

-- 
Unsubscribe: send email to links-list-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message



More information about the links-list mailing list