[links-list] Re: BUG in forms

Mikulas Patocka mikulas at artax.karlin.mff.cuni.cz
Wed May 1 05:53:03 PDT 2002


On Wed, 1 May 2002, Petr Baudis wrote:

> Dear diary, on Wed, May 01, 2002 at 01:27:17PM CEST, I got a letter,
> where Anders Widman <andewid at tnonline.net> told me, that...
> > Sure. This is what happens:
> >
> > I am trying to post in a forum. To read a thread and reply to it I go
> > to the following url
> > http://www.lka.nu/castle/tavernroom.php?thread=115 where 115 is this
> > particular forum/thread.
> >
> > The sourcecode for the form that should be submitted is like this:
> >
> >
> > <form method="post">
> > <input type="hidden" name="action" value="reply">
> > <textarea name="content" rows="8" cols="50" style="width='590px'"></textarea><br><br>
> > <input type="submit" value="Post Reply">
> >
> > So, when a user press submit the values/data of the form should be
> > submitted to the originating url
> > (http://www.lka.nu/castle/tavernroom.php?thread=115). The problem is
> > that this URL already contains "?thread=115" which seem to confuce
> > Links/ELinks. So wha Links does is to just cut off the "?thread=115"
> > part and insert the form.
> >
> > So, what should look like this:
> > http://www.lka.nu/castle/tavernroom.php?thread=115&action=reply&content=fldjflkjdfljd
> >
> > is submitted as:
> >
> > http://www.lka.nu/castle/tavernroom.php?action=reply&content=fdlfkdflkjdfd
>
> Hmm, there's apparently code dedicated specially for striping anything
> behind '?' from the URL when there's no action attribute. I can't see
> reason for it, so I just now commented it out for now. Mikulas?

For GET this code is required. You can remove it for POST method.

Mikulas

-- 
Unsubscribe: send email to links-list-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message



More information about the links-list mailing list