[links-list] Re: Problem configuring links 2.0pre1

Arkadiusz 'Jo Joro' Sochala jojoro at poczta.onet.pl
Wed May 22 22:01:07 PDT 2002


> I try to configure links-2.0pre1 on my Linux and i got this :

> [...]
> checking for png.h... no
> checking for png_create_info_struct in -lpng... yes
> configure: error: You need libpng to compile Links in graphics mode

> But I have libpng-1.2.2 installed...

If you have pkg-config installed, then just type:
CPPFLAGS="`pkg-config libpng12 --cflags`" ./configure --enable-graphics...

or if you don't have pkg-config:
CPPFLAGS="-I/usr/include/libpng12" ./configure --enable-graphics...

or upgrade libpng to 1.2.3 version

	Jo Joro
-- 
Unsubscribe: send email to links-list-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message



More information about the links-list mailing list