sspspecs patches

Robert Connolly robert at linuxfromscratch.org
Thu Dec 30 14:44:28 PST 2004


Hello. Please remove:

gcc-2.95.3-sspspecs-3.patch
gcc-3.3-sspspecs-4.patch
gcc-3.4-sspspecs-3.patch

Please add the attached patch. The last one was supposed to make c++ use ssp, 
but it didn't. Looks like -shared-libgcc is always defined with g++ and so 
-fstack-protector-all wasn't being used. Its fixed in this patch.

Please symlink:
gcc-2.95.3-sspspecs-5.patch
gcc-3.3-sspspecs-5.patch
and
gcc-3.4.3-sspspecs-5.patch
to
gcc-3.4-sspspecs-5.patch

I'm skipping over -4 because the 3.3 patch is a version higher, and this is 
easier and less confusing all around.

Thanks
robert
-------------- next part --------------
A non-text attachment was scrubbed...
Name: gcc-3.4-sspspecs-5.patch
Type: text/x-diff
Size: 5012 bytes
Desc: not available
URL: <http://lists.linuxfromscratch.org/pipermail/patches/attachments/20041230/006ec20f/attachment.patch>


More information about the patches mailing list