Patches - Discussion

Tushar Teredesai linux_from_scratch at yahoo.com
Mon May 3 16:01:02 PDT 2004


Jim Gifford wrote:

>    I'm getting a little concerned about that state of patches as I
>explained to Matthew today on IRC. It seems that we are getting a lot of
>patches, that should be sent up to the upstream maintainers. We are also
>getting patches that are not mentioned in any LFS project, example the
>recent gv patche. Matthew and I agree, that the patches project should have
>the stipulation stating the patch must have an upstream status. Patches
>should also only be related to LFS, BLFS, HLFS, BE-LFS, hints, and any other
>LFS related project.
>  
>
The patches is meant to be a catch-all for all patches, even for 
packages that are not mentioned in the book.

+1 for changing the patch requirements to make the upstream-status field 
a *must have*.

>    It has been asked to me numerous times to use the following patch name
>structure, (package name version "the same as the archive")-(brief
>description)-(version).patch. The reason for this is to keep the packages
>named the same as the archives and keep consistency. This was requested by
>numerous folks using scripts to download patches and sources. So a patch
>that is for cracklib would look like - cracklib,2.7-cleanup-1.patch -
>because the archive is cracklib,2.7.tar.gz
>  
>
AFAIR, this was discussed when the guidelines were designed. Having a 
consistent naming structure $(packageName)-$(packageVersion)....patch is 
useful since the maintainers sometimes tend to change the names of the 
tarballs between versions. For example, they will name the tarball 
mypackage-0.1.tar.bz2 for the 0.1 release; for the next one they will 
name it mypkg-0.2-src.tar.gz; for the next they will rename it to 
mypackage_0.3.tar.gz.

>A new patch header is need to show the upstream status. Several of us who
>create patches have added this to our patches recently. The new header would
>look like this.
>
>Submitted By:
>Date:
>Initial Package Version:
>Origin:
>Upstream Status:
>Description:
>  
>
The field is already there in the submission guidelines 
<http://www.linuxfromscratch.org/patches/submit.html>. Currently, it is 
marked as optional. The only change needed would be to make it Required.

-- 
Tushar Teredesai
  mailto:tushar at linuxfromscratch.org
  http://linuxfromscratch.org/~tushar



	
		
__________________________________
Do you Yahoo!?
Win a $20,000 Career Makeover at Yahoo! HotJobs  
http://hotjobs.sweepstakes.yahoo.com/careermakeover 



More information about the patches mailing list