r1990 - in trunk: . agg

ken at linuxfromscratch.org ken at linuxfromscratch.org
Wed Oct 15 16:21:05 PDT 2008


Author: ken
Date: 2008-10-15 17:21:05 -0600 (Wed, 15 Oct 2008)
New Revision: 1990

Added:
   trunk/agg/
   trunk/agg/agg-2.5-libtool22_fix-1.patch
Log:
Enable current agg to build when libtool-2.2 is installed.

Added: trunk/agg/agg-2.5-libtool22_fix-1.patch
===================================================================
--- trunk/agg/agg-2.5-libtool22_fix-1.patch	                        (rev 0)
+++ trunk/agg/agg-2.5-libtool22_fix-1.patch	2008-10-15 23:21:05 UTC (rev 1990)
@@ -0,0 +1,24 @@
+Submitted By: Ken Moffat <ken at linuxfromscratch dot org>
+Date: 2008-10-15
+Initial Package Version: 2.5
+Upstream Status: unknown
+Origin: Opensuse
+Description: Allows agg-2.5 to link with libtool-2.2
+
+diff -Naur agg-2.5.orig/configure.in agg-2.5/configure.in
+--- agg-2.5.orig/configure.in	2006-10-09 05:06:36.000000000 +0100
++++ agg-2.5/configure.in	2008-10-15 22:36:39.000000000 +0100
+@@ -121,6 +121,13 @@
+   AC_MSG_WARN([*** X11 not found! Omitting X11 layer.])
+ fi
+ AM_CONDITIONAL(ENABLE_X11,[test x$no_x = x -a xno != x$enable_platform -a x$win32_host != xyes])
++if test x"$x_includes" = x; then
++ x_includes="/usr/include"
++fi
++AC_SUBST(x_includes)
++if test x"$x_libraries" = x; then
++ x_libraries="/usr/lib"
++fi
+ AC_SUBST(x_includes)
+ AC_SUBST(x_libraries)
+ dnl ###############################################




More information about the patches mailing list